Введение.
В настоящее время Интернет занимает значительное место в жизни каждого человека. И что может быть привлекательнее, чем грамотно и красиво оформленная страница? Все больше и больше разработчиков в своих web-страницах используют flash-анимацию. Это может быть и реклама, так раздражающая некоторых пользователей, меню, достаточно продолжительные мультфильмы или даже обучающие приложения. В этом учебном курсе Вы научитесь обращаться с программой создания flash-анимации. Поверьте, это увлекательное, хотя порой и достаточно сложное занятие. 

В первых нескольких уроках я предложу вашему вниманию обзор элементов, позволяющих перенести вашу мысль в компьютер, в кадр Вашего будущего проекта. Еще одно мгновение и вы научите Ваше творение реагировать на действия пользователя, а тут уже и не далеко до профессионализма!

Урок 1. «С чего же начать?»
Страница приветствия
Начните с того, что запустите Flash 8. 
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Рис.1 – страница приветствия 
На рис.1 представлена страница, появляющаяся при загрузке Macromedia Flash 8.0. Чтобы создать новый проект flash-ролика необходимо кликнуть по строке Flash Document, расположенной в столбце Create New. Для того, чтобы открыт уже существующий документ кликните по строке Open… в колонке Open Recent Item.
Также можно использовать меню File ► New… (сочетание клавиш Ctrl+N) и File ► Open…(сочетание клавиш Ctrl+O) для создания нового файла и открытия существующего соответственно.

Теперь считаю необходимым вкратце рассказать об интерфейсе самой программы. После того как вы создали новый проект, появляется пространство для действий (рис.2)
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Рис. 2 – интерфейс пользователя

Рабочая область и сцена.
Сцена – это область окна документа, в которой Вы можете рисовать кадры Вашего будущего фильма. В одном фильме может быть несколько сцен. Они не обязательны, так как можно поместить весь фильм в одну сцену, но при наличии большого числа объектов легче и удобнее разделить фильм не сцены. Поменять местами сцены не составляет особого труда, а вот поменять местами кадры в одной сцене уже проблема. Сцены просматриваются по очереди, то есть сначала все кадры первой сцены, потом все кадры второй и так далее.

Если открыть список, обозначенный на рис.2 цифрой 1, то можно выбрать масштаб просмотра. Выберите масштаб 50%. Белая область – это сцена, серый фон – рабочая область. Снизу и справа расположены полосы прокрутки, который позволяют прокручивать рабочую область вместе со сценой.
Рабочая область предназначена для рисования и временного размещения объектов. При публикации фильма (его размещении) останется только содержимое сцены. Объекты, оставшиеся за сценой, в рабочей области, показываться не будут. Также неплохо размещать в рабочей области запасные контуры и изображения, так как испортит их очень легко, а при  работе с достаточно сложных решениях его восстановление требует больших затрат времени. 
Если вы не планируете использовать рабочую область, то её можно временно убрать в меню View ► Work Area (Вид ► Рабочая область). При этом для редактирования доступна только Сцена.

Временная линейка и панель слоёв
С помощью Временной линейки определяется длительность фильма, время появления каждого кадра при проигрывании фильма, а также периоды жизни разных объектов. В левой её части расположена Панель слоев, позволяющая размещать объекты на разных слоях, что позволяет независимо управлять режимами их просмотра и редактирования. Убрать и вывести временную линейку на экран можно через меню Window ► Timeline (Окно ► Временная линейка).
Палитра инструментов
В Палитре инструментов собраны все инструменты, с помощью которых Вы будете рисовать контуры, выбирать их, редактировать, перемещать их в окне и делать многое другое. Чтобы выбрать инструмент щелкните на нём. Убрать и вывести палитру инструментов на экран можно через меню Window ► Tools (Окно ► Инструменты).
Палитра инструментов состоит из нескольких разделов. В верхнем разделе Tools (Инструменты) находятся собственно инструменты, с помощью которых создаются и редактируются объекты. В разделе View (Вид) находятся два инструмента, с помощью которых можно менять масштаб просмотра и перемещать сцену в окне. В разделе Colors (Цвета) находятся элементы управления активными цветами, то есть выбираются цвета для обводки и заливки контуров.

При выборе инструмента из первого раздела в разделе Options (Параметры) появляются кнопки-модификаторы, позволяющие выбирать разные режимы работы инструмента и менять его параметры.












На рис.3 выбран инструмент Arrow (Стрелка), с помощью которого выделяют и редактируют контуры. Внизу, в разделе Options Вы видите кнопки, позволяющие выполнять редактирование выделенных объектов: Smooth (Скругление) и Straighten (Спрямление). Кнопка Snap to Objects (Привязка к объектам) позволяет без затруднения привязываться к контурам других объектов. 
Урок 2. «Немного теории»

Координатные линейки
Координатные линейки находятся над окном документа и слева от него как показано на рис.4. По умолчанию они отключены, но Вы всегда можете их отобразить через меню View ► Rules (Вид ► Линейки)  или нажатием сочетания клавиш Ctrl + Alt + Shift + R. Ещё проще отобразить линейки можно нажав правой кнопкой мыши на сцене и выбрав пункт Rules (Линейки). Линейки можно настроить, задав для них свои единицы измерения. Для этого необходимо воспользоваться пунктом меню Modify ► Document (Изменить ►  Документ) и выбрать нужную единицу измерения в раскрывающимся списке Rules Units (Единицы измерения линейки).
Направляющие

Направляющие служат для выравнивания объектов, для задания общих границ изображения или границ отдельные его частей, а также для контроля вертикальности и горизонтальности. Это вспомогательные линии зелёного цвета, которые не выводятся на печать и не отображаются при просмотре и публикации фильма. Чтобы включить или выключить режим показа направляющих используйте меню View ► Guides ► Show Guides (Вид ► Направляющие ► Показать направляющие) или сочетание клавиш Ctrl + ; . Поочерёдное выполнение этой команды или включает или отключает направляющие. Также включение и отключение направляющих осуществляется нажатием правой кнопки мыши на сцене и выборе пункта Guides ► Show Guides (Направляющие ► Показать направляющие)
Чтобы создать направляющие необходимо сначала включить отображение координатных линеек, как описано ранее, а затем нажать кнопку левую мыши на линейке и перетащить её в на сцену. Таким образом вертикальная направляющая получится при перетаскивании вертикальной линейки, горизонтальная – при перетаскивании горизонтальной линейки.

Для того чтобы нечаянно не сдвинуть направляющие при работе с объектами, необходимо их блокировать. Для этого можно воспользоваться меню View ► Guides ► Lock Guides (Вид ► Направляющие ► Блокировать направляющие) или сочетанием клавиш Ctrl + Alt + ; . Поочерёдное выполнение этой команды включает или отключает направляющие. Также можно блокировать/разблокировать направляющие, щелкнув на сцене правой кнопкой мыши и выбрав в появившемся меню Guides ► Lock Guides (Направляющие ► Блокировать направляющие). Эти команды действуют только на существующие направляющие. Направляющие, созданные после этого можно будет перемещать. Однако можно сделать так, чтобы все новые направляющие блокировались сразу же после создания. Для этого необходимо воспользоваться пунктом меню View ► Guides ► Edit Guides (Вид ► Направляющие ► Изменить направляющие) или щёлкнуть правой кнопкой мыши на сцене и выбрать пункт Guides ► Edit Guides (Направляющие ► Изменить направляющие). В появившемся диалоговом окне (рис. 5) необходимо выставить флажок Lock Guides (Блокировать направляющие).
В этом же окне можно выбрать цвет направляющих. Для этого щелкните на кнопке Color (Цвет) и выберите нужный в открывшейся палитре цветов.
Для удаления всех направляющих сцены следует щелкнуть в этом окне на кнопку Clear All (Очистить всё). При этом удалятся даже заблокированные направляющие. Также удалить все можно щелкнув на сцене правой кнопкой мыши и выбрав в появившемся меню Guides ► Clear Guides (Направляющие ► Очистить направляющие).

Сетка
При рисовании и размещении объектов можно добиться бόльшей точности, если использовать такой инструмент как сетка. Чтобы вывести её на экран, выполните команду View ► Grid ► Show Grid (Вид ► Сетка ► Показать сетку) или щёлкнуть правой кнопкой мыши на сцене и выбрать пункт Grid ► Show Grid (Сетка ► Показать сетку). 

По умолчанию линии сетки проходят через каждые 18 пикселей, но можно изменить шаг в окне настройки сетки. Для этого необходимо выполнить команду View ► Grid ► Edit Grid (Вид ► Сетка ► Изменить сетку) или щёлкнуть правой кнопкой мыши на сцене и выбрать пункт Grid ► Edit Grid (Сетка ► Изменить сетку). 
В появившемся окне (рис. 7) введите новые значения шагов по горизонтали и вертикали в поля, слева от которых нарисованы соответствующие стрелки. В этом же окне с помощью кнопки Color (Цвет) другой цвет вместо стандартного серого. Настройка сетки и направляющих действует только на текущий фильм. 
Привязка к сетке, направляющим и объектам

При рисовании контуров и их перемещении,  а также при вводе текста можно включить режим привязки к сетке и направляющим, когда опорные точки контура или базовая линия текста «привязывается» к ближайшему узлу сетки или направляющей. Это позволяет достаточно точно выравнивать объекты. Здесь стоит отметить, что если размещаемый объект окажется на одинаковом расстоянии от узла сетки и направляющей, то он «притянется» к направляющей, так как этот режим привязки имеет бόльший приоритет. 
Для включения режима привязки можно воспользоваться окном настройки сетки (рис. 7), выставив там флажок Snap to Grid (Привязать к сетке) или нажать правой кнопкой мыши на сцене и в появившемся меню выбрать пункт Snapping (Привязка), где необходимо выставить флажки:

· Snap Align – Привязка рядом
· Snap to Grid – Привязка к сетке

· Snap to Guides – Привязка к направляющим

· Snap to Pixels – Попиксельная привязка
· Snap to Objects – Привязка к существующим объектам

Первый пункт Snap Align позволяет привязываться не к самим контурам объектов а к некоторому стандартному расстоянию от них. 
Edit Snapping вызывает окно настройки привязки. Здесь по нажатию кнопки Advanced (Дополнительно) появляется настройки Snap Align, где в поле Stage Border можно указать какое именно расстояние до объекта должно выдерживаться.

Инструмент Hand
Перемещать рабочую область и сцену в окне можно либо с помощью полосок прокрутки либо с помощью инструмента Hand (Рука). Выберите этот инструмент. Наведя на рабочую область или сцену указатель мыши примет вид руки. Зажмите кнопку мыши на любом месте изображения и тащите его, как двигаете лист бумаги на столе. Пока вы не отпустите кнопку мыши, лист будет следовать за указателем как приклеенный. 
Если при работе с другими инструментами Вам понадобилось немного подвинуть сцену, то удобнее временно заменить этот инструмент на Hand (Рука). Для этого необходимо держать клавишу пробела. После того, как вы отпустите пробел, вернётся тот инструмент, которым вы пользовались до этого.
Панель слоёв

Панель слоёв располагается в левой части временной линейки (Рис.10). При создании нового фильма там расположен лишь один слой Layer 1 (Слой 1).  Каждая строка панели описывает один слой. Одна из строк обязательно выделена. Это активный слой – слой, на котором можно рисовать новые объекты, редактировать старые или вставлять объекты из буфера обмена. Чтобы активизировать другой слой щёлкните по его имени. 
Чтобы создать новый слой щёлкните по кнопке Insert Layer (Вставить слой) внизу панели слоёв или выполните команду Insert ► Layer (Вставить ► Слой). Если вы хотите удалить слой, то достаточно сделать его активным и щёлкнуть по кнопке Delete Layer (Удалить слой) внизу панели слоёв. Слой удаляется вместе со всеми своими объектами во всех кадрах фильма.
Если вы хотите временно отключить видимость слоя, то для этого необходимо нажать на точку справа от имени слоя, расположенную в колонке «Глаз». Для того чтобы заблокировать слой от редактирования нужно нажать на точку, расположенную справа от имени слоя в колонке «Замок»

Порядок наложения слоёв

При наложении объектов с разных слоёв друг на друга они закрывают друг друга как карты в стопке. Слои накладываются друг на друга в том же порядке, в котором располагаются их строки: чем выше строка, тем выше слой. Чтобы изменить порядок наложения слоёв надо поменять местами их имена в панели слоёв. Чтобы перетащить слой нажмите кнопку мыши на строке с его именем и перетащите указатель на границу между слоями, куда должен встать перемещаемый слой. Когда в этом месте появится тёмная полоска, отпустите кнопку мыши. Чтобы вставить слой на самый верх, перетащите его на верхнюю границу панели слоев, а для перемещения его на самый низ – на её нижнюю границу.

Урок 3. «Начинаем рисовать»

Выбор цвета

Посмотрите на палитру инструментов. В разделе Colors (Цвета) расположены текущие цвета обводки и заливки. Рядом с индикатором цвета обводки – значок карандаша, а рядом с индикатором заливки – значок ведра с краской. Ниже расположены три кнопки:

· Цвета по умолчанию – задаёт белый цвет для заливки и чёрный для обводки

· Прозрачность – делает текущий цвет прозрачным для обводки или заливки в зависимости от того, какой индикатор выбран

· Меняет цвета обводки и заливки местами

Чтобы установить новый текущий цвет щёлкните на соответствующем индикаторе. При этом откроется цветовая палитра. Чтобы сделать выбор – щелкните на квадратике с понравившимся цветом.
Стиль и толщина линий

Для выбора атрибутов обводки нужно выбрать инструмент Pencil Tool (Карандаш). Внизу экрана появится панель обводки. 

В верхнем раскрывающемся списке выберите стиль обводки. Для выбора толщины линии воспользуйтесь полем слева от стиля линии. По умолчанию толщина линии равна 1. Изменение толщины линии возможно для всех кроме первой: Hairline (Волос).

Слева на панели также находится индикатор цвета такой же, как на панели инструментов. Изменение цвета здесь также дублируется и на панели инструментов.

Прямые линии
Чтобы нарисовать прямую линию выберите инструмент Line (Линия). Указатель мыши примет вид крестика. Нажмите кнопку мыши в любом месте сцены и, не отпуская кнопку, тащите  указатель в нужном направлении. За ним потянется прямая линия. Когда длина отрезка будет достаточной, отпустите кнопку мыши. Чтобы нарисовать строго горизонтальную, строго вертикальную линию, или линию расположенную под углом в 45о держите нажатой клавишу Shift. 

При рисовании линии вокруг указателя появляется кружок, когда прямая совпадает с горизонталью или вертикалью. В режиме включенной привязки кружок также появляется при совпадении указателя с узлами сетки или пересечением направляющих.

С помощью инструмента Line (Линия) можно рисовать не только одиночные отрезки, но и ломаные линии, замкнутые многоугольники. Для этого следует включить режим привязки к объектам. При попадании указателя в зону привязки вокруг него также появляется кружок.

Прямоугольники и эллипсы

Выберите инструмент Rectangle (Прямоугольник). Установите указатель в угол будущего прямоугольника, нажмите кнопку мыши и тащите его в противоположный угол.  Когда прямоугольник достигнет нужных размеров, отпустите кнопку мыши. Чтобы нарисовать квадрат, тащите указатель при нажатой клавиши Shift.
Можно рисовать прямоугольник с закругленными краями. Для этого выберите инструмент Rectangle (Прямоугольник). В панели инструментов в разделе Options (Свойства) выберите Set Corner Radius (Установить радиус скругления). В появившемся окне укажите нужный радиус скругения в пикселях. Чтобы вернуться к обычным прямоугольникам укажите в качестве значения радиуса «0».

Эллипсы рисуются также как и прямоугольники, но другим инструментом: Oval (Овал). Если держать нажатой клавишу Shift, то будет нарисована окружность.
Рисование пером
Выберите инструмент Pen (Перо). Щёлкните в одной точке, затем в другой, в третьей и т.д. Тем самым вы создадите несколько опорных точек, а программа автоматически соединит их отрезками прямых. Обратите внимание на то, что, когда вы начинали рисовать, справа от пера был крестик. Это означает, что вы начинаете новый контур. Его отсутствие означает, что продолжается предыдущий контур. Что бы закончить контур необходимо в последней точке щёлкнуть дважды.

Для рисования строго вертикальных, горизонтальных и расположенных под 45о отрезков, создавайте опорные точки при нажатой клавише Shift.
Если вы хотите нарисовать замкнутый контур, то необходимо последнюю точку поставить точно на место первой точки контура. Вы узнаете что попали в точку привязки когда появится кружочек справа от указателя, и вы гарантированно попадёте в эту точку. Контур при этом автоматически заканчивается, закрашивается и вы можете сразу же начинать рисовать следующий. Если контур не закрасился, значит вы промахнулись и контур не замкнулся. 
Рисуя инструментом Pen (Перо) вы можете временно переключаться на режим Hand (Рука) чтобы передвигать сцену, не прекращая рисования. Для переключения держите нажатой клавишу пробела. 

Рисование гладких кривых

Кривые линии можно рисовать тем же инструментом Pen (Перо), но делать это несколько сложнее.

Возьмите инструмент Pen (Перо). Установите указатель на пустом месте сцены, нажмите левую кнопку мыши и, не отпуская её, видите указатель строго вверх (рис. 14а). Чтобы делать это было проще, нажмите и удерживайте клавишу Shift. Отпустите кнопку мыши, а затем Shift.
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Вы видите, что из опорной точки, которую вы таким образом создали выходят направляющие прямые (манипуляторы кривизны)– касательные к кривой в данной точке. На их концах находятся направляющие точки. Чем меньше расстояние от опорной до направляющей точки, тем круче получится кривая. 
Теперь установите указатель в другое место, снова нажмите кнопку и тащите указатель прямо вниз (рис. 14б). В итоге вы получите дугу. Продолжите ту же кривую, нарисовав ещё одну опорную точку. На этот раз не отпускайте сразу кнопку мыши а подвигайте указатель в разные стороны и понаблюдайте как зависит форма линии от длины и направления манипулятора. Чтобы закончить контур, щёлкните в любом месте страницы, держа клавише Ctrl.
Если вам нужно продолжить завершённый контур, то щёлкните на нём пером (контур выделится), далее щёлкните пером в конечной точке контура и продолжите рисование. Можно наоборот, нарисовать линию, а затем присоединить её к выбранному контуру, щелкнув в одной из его конечных точек. Таким образом можно собрать контур из нескольких кусков. Более того, вы можете пририсовать к контуру несколько линий, присоединяя их не к конечным точкам, а к любым промежуточным. Это можно также проделать и с замкнутым контуром.

Использование карандаша
Процесс рисования инструментом Pencil (Карандаш) похож на рисование карандашом на листе бумаги: линия повторяет траекторию движения указателя. При рисовании карандашом Flash самостоятельно расставляет опорные точки в зависимости от сложности вашей кривой. Затем вы сможете отредактировать их: передвинуть, удалить, добавить новые, покрутить манипуляторы кривизны. 

Существует три режима рисования карандашом (рис. 15):

· Straighten (Спрямление) – распрямляет получившиеся неровности и преобразует получившуюся фигуру к линии, окружности, прямоугольнику и т.д.
· Smooth (Скругление) – сглаживает все острые углы, форму контура меняет незначительно

· Ink (Чернила) -  контур остаётся без изменений, таким, как вы его нарисовали.

Рисование и закрашивание кистью

Инструмент Brush (Кисть) можно использовать как для рисования новых, так и для закрашивания существующих контуров. Рисуют кистью также как карандашом, но вместо линий она рисует замкнутый контур с заливкой, но без обводки. При выборе этого инструмента в поле Options (Свойства) появляется панель настройки кисти. Установите здесь нужные вам свойства кисти. 
Урок 4. «Работа с контурами»

Выделение контуров и опорных точек
Нарисуйте пером какой-нибудь контур из кривых и прямых сегментов. Для выделения опорных точек и сегментов выберите инструмент Subselect (Выделение). Чтобы просто увидеть все опорные точки щёлкните на контуре один раз. Тем самым мы выделяем контур. Обратите внимание, что все точки изображены виде сплошных квадратиков. Это значит, что они выделены.

Теперь щёлкните по одной из точек. Она выделится, и это отразится на её виде. В зависимости от её типа она станет полям квадратиком (угловая точка) или кружочком (гладкая точка). Если у точки есть манипуляторы, то они станут видимыми. Кроме того вы увидите по одному манипулятору у соседних с ней точек. Держа нажатой клавишу Shift, щёлкните по очереди на других опорных точках – они тоже выделятся.
Несколько соседних точек можно выделить, обведя их рамкой с помощью того же инструмента Subselect (Выделение). Для этого установите чуть выше и левее нужных точек, нажмите кнопку мыши и вытяните рамку так, чтобы в неё попали все нужные точки. Затем отпустите кнопку мыши. Если в одну рамку все нужные точки вместить не удаётся, то обведите точки второй рамкой при нажатой клавише Shift. 
Чтобы снять выделение с контура, щёлкните на пустом мете сцены или выделите другой контур.

Перемещение опорных точек

Выделенная опорная точка перемещается инструментом Subselect (Выделение). При перемещении опорных точек на кривых могут появляться новые опорные точки. Они также обязательно появляются на пересечении линий. 
Перемещать группу точек не очень удобно. Приходится использовать для этого клавиши-стрелки. Передвигать можно любое количество опорных точек. 
На месте остаются невыделенные точки, все выделенные передвигаются одновременно в одном и том же направлении. Однако одновременное перемещение точек ограничено некоторыми условиями. Так, когда несколько соседних точек кривой выстраивается по одной прямой, средние точки исчезают. Поэтому, вообще говоря, лучше перемещать точки по отдельности, а перемещение нескольких точек использовать только для небольшой коррекции.

Рассмотрим пример перемещения опорных точек. Для начала возьмите инструмент Pen (Перо) и нарисуйте окружность (рис.17а). Выберите инструмент Subselect (Выделение) и выделите контур, а затем правую опорную точку окружности (рис 17б). Потяните верхний её манипулятор вправо и вверх (рис. 17в). В зеркальном порядке повторите все с левой опорной точкой окружности. 
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Манипуляторы одной точки можно перемещать и по отдельности. Так выделите нижнюю точку окружности и потяните её правый манипулятор, удерживая клавишу Alt вправо вверх, а левый влево вверх (рис. 17в). Теперь манипуляторы верхней точки необходимо переместить вверх (17г). Так можно получить незамысловатый рисунок.
Создание и удаление опорных точек

Более радикально можно изменить форму контура, добавив новые опорные точки или удалив существующие. Кроме того, при редактировании контуров Flash часто добавляет новые гладкие точки, что мешает дальнейшему редактированию. В таких случаях лишние точки можно удалять.

Чтобы создать новую точку на кривом сегменте, достаточно щелкнуть в нужном месте пером. При попадании указателя на кривой сегмент рядом с ним появляется значок плюса. На прямом сегменте почему-то дополнительную точку таким образом поставить не удается и приходится пускаться на хитрости. Проще всего провести прямую от нужной точки сегмента до того места, куда эту точку надо переместить, а затем слить эти две точки, перетащив первую точку на вторую. Для создания симметричных многоугольников можно нарисовать прямые, пересекающие всю фигуру насквозь. 
Для того, чтобы нарисовать, например, четырёхконечную звезду повторите следующие действия. Воспользуйтесь инструментом Oval (Овал) и, удерживая клавишу Shift нарисуйте две окружности как показано на рис.18а. Если вам не удалось попасть в центр, то подгоните малую окружность внутри большой. Для этого щёлкните на ней мышью и с помощью стрелок на клавиатуре подгоните её под центр. 
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Далее выберите инструмент Subselect (Выделение). Выделите верхнюю точку и перетащите её на другую окружность. Для облегчения включите режим привязки к объектам (см. Урок 2: Привязка к сетке, направляющим и объектам). Также растащите ещё три точки (рис. 17б). После этого необходимо удалить всё лишнее. Для этого выделяем все ненужные поля и контуры, зажав клавише Shift (рис.17в) и нажимаем клавишу Del (рис. 18г). Всё, наша фигура готова.
Для удаления опорных точек есть два способа. Во-первых, можно выделить одну или несколько опорных точек инструментом Subselect (Выделение) и нажать клавишу Del. Во-вторых, можно щёлкнуть на точке инструментом Pen (Перо). Если точка угловая без манипуляторов, то она сразу исчезнет. Если у неё есть манипуляторы, то они исчезнут. Щёлкните на такой точке ещё раз и она будет удалена. 
Группировка контура

После того как контур отредактирован, лучше всего сгруппировать его точки. В таком виде опорные точки контура нельзя увидеть, и контур можно перемещать только целиком. Такой контур нельзя редактировать, зато вы не сможете нечаянно испортить его, сдвинув какую-нибудь опорную точку, изогнув сегмент или просто задев им другой контур на том же слое. Группировка контура не мешает трансформировать его, то есть менять его размеры, вращать, перекашивать и зеркально отражать. Как это делается, вы узнаете в последующих уроках.

Чтобы сгруппировать контур, выделите его инструментом Subselect (Выделение) и нажмите клавиши Ctrl+G или выполните команду Modify ► Group (Изменить ► Сгруппировать). Вокруг контура появляется голубая прямоугольная рамка. Это габаритная рамка, описанная вокруг группы. При выделении сгруппированного контура вы будете видеть ее, а не опорные точки.

Если возникнет необходимость поработать с опорными точками контура, временно разгруппируйте его. Для этого дважды щелкните на нем инструментом Arrow (Стрелка). Остальные объекты при этом блокируются и никак не мешают редактированию. Работать в таком режиме вы можете только с разгруппированным контуром. Окончив работу, дважды щелкните на пустом месте, и контур снова будет сгруппирован, а остальные объекты освобождены.

Чтобы разгруппировать контур совсем, щелкните на нем и выполните команду Modify ► Ungroup (Изменить ► Разгруппировать) или нажмите клавиши Ctrl+Shift+G.
Выделение и перенос областей контура

Продемонстрируем это действие на примере. 

Нарисуйте круг. Выберите инструмент Arrow (Стрелка) и обведите рамкой прямоугольную область контура (рис. 19а). Часть заливки и обводки выделится. Щелкните на ней и перетащите на другое место. Внутри контура образуется прямоугольный вырез (рис. 19б).

Теперь вырежем отверстие более сложной формы. Выберите инструмент Lasso (Лассо), нажмите кнопку мыши внутри заливки и, не отпуская кнопки, обрисуйте область произвольной формы (рис 19в). Замкните область выделения, отпустив кнопку мыши вблизи от начальной точки. Эти две точки соединятся прямой, и область выделится. Нажмите на ней кнопку мыши и оттащите в сторону. Внутри заливки образуется прозрачное пятно — вырез (рис. 19г). 
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Вместо инструмента Lasso (Лассо) можно также использовать Polygon Mode (Режим многоугольника). Для этого при выборе инструмента Lasso (Лассо) в поле Options (Свойства) нажмите модификатор Polygon Mode (Режим многоугольника).
Пересечение и наложение контуров

Есть еще одна особенность рисования в редакторе Flash: при пересечении линий и замкнутых контуров с обводкой их обводка и заливка разрезаются в местах пересечения (рис. 20а). Этим свойством можно пользоваться, чтобы разрезать фигуры и линии на части. Обратите внимание: если пересекающую линию убрать, не растащив предварительно заливку и обводку на части, целостность фигуры восстанавливается.

При наложении заливок без обводки друг на друга они ведут себя по-разному в зависимости от их цветов. Если обе заливки одного цвета, они сливаются в одну фигуру (рис. 20в). Если они разного цвета, то верхняя заменяет собой нижнюю. Если ее затем оттащить в сторону, на ее месте останется пустое место (рис. 20б). Это свойство можно использовать, с одной стороны, для создания сложных фигур из более простых, а с другой стороны, для выполнения различных вырезов и масок.
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Урок 5. «Работа с цветом»

Замена атрибутов заливки и обводки

Цвета, которые вы использовали при рисовании контура, в любой момент можно изменить. Для перекрашивания выделенных контуров подойдут те же инструменты, которыми вы выбирали текущие цвета, то есть индикаторы заливки и обводки из палитры инструментов и панели Fill (Заливка) и Stroke (Обводка), а панели свойств помогут вам задать другую толщину линии или ее стиль, а также сменить тип заливки. Кроме того, для окрашивания замкнутых областей текущим цветом удобно пользоваться инструментом Paint Bucket (Ведро с краской), а для окрашивания линий – инструментом Ink Bottle (Чернильница). Для этого контуры даже не надо выделять.

Возьмите инструмент Line (Линия) и нарисуйте решётку произвольной формы (рис. 21а). Теперь выберите инструмент Paint Bucket (Ведро с краской) и, выбирая для каждого прямоугольника свой цвет, закрасьте их (рис. 21б). Чтобы заменить заливку укажите необходимый цвет и заново залейте нужный прямоугольник. Вы заметили, что невозможно закрашивать незамкнутые контуры. Это сделано для того, чтобы случайно не залить всю сцену каким-нибудь цветом, думая, что закрашиваемая фигура замкнута. 
Для того, чтобы заменить цвет обводки, щёлкните на инструменте Ink Bottle (Чернильница) и укажите необходимый цвет в поле Stroke Color (Цвет обводки). Далее, указывая цвета каких линий и контуров нужно изменить, добиваемся интересующего нас результата (рис. 21в).
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Градиентная заливка

Градиентная заливка представляет собой плавный переход от одного цвета к другому и может быть использована также и для обводки. Она может быть линейной или радиальной. Стандартную заливку можно выбрать и в палитре цветов, но чтобы задать в ней другой цвет или создать переход между несколькими цветами, надо воспользоваться панелью Fill (Заливка). Выберите в раскрывающемся списке этой панели тип заливки: Linear Gradient (Линейный градиент) или Radial Gradient (Радиальный градиент) (рис. 22а ). 
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Рис. 22. Панель заливки
Внизу панели находятся стандартный цвета заливки. При выборе любого из них справа на экране появляется панель настройки градиентной заливки (рис. 22б). Цвета ползунков определяют цвета перехода, а их положение – его ширину. Для управления цветом обоих ползунков служит индикатор цвета сверху от шкалы. Снизу от шкалы находится окно предварительного просмотра. В нем отражаются все действия над градиентом, чтобы вы могли представить, как будет выглядеть заливка при данной настройке.

Работать с градиентными заливками достаточно просто, так что выполним редактирование градиентной заливки на практическом примере.

Выберите инструмент Paint Bucket (Ведро с краской) и в качестве цвета заливки укажите градиентную заливку. Теперь щёлкните на инструмент Oval (Овал) и нарисуйте круг, для чего удерживайте нажатой клавишу Shift. Вы видите, что он автоматически закрасился градиентом (рис. 23а). Сделаем градиентный переход более резким. Для этого выберите инструмент Selection (Выделение) и щёлкните один раз по заливке. Теперь переместите один или оба ползунка к центру (рис. 23б). Усложним градиентный переход, добавив к нему еще два цвета. Верните ползунки на крайние позиции и добавьте к ним еще два ползунка, щелкнув прямо под шкалой градиентов, как показано на рис. 23в. Задайте цвета для этих ползунков. Получившийся контур должен выглядеть примерно так, как на рис. 23г.
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Рис. 23: Градиентная заливка

Линейный градиент создаётся аналогично радиальному, только для этого необходимо в панели настройки градиента в поле Type (Тип) выбрать значение Linear (Линейный). 

Настройка градиентной заливки

Градиентную заливку можно поворачивать, делать переходы более резкими и сдвигать центр цветового перехода с помощью инструмента Paint Bucket (Ведро с краской). 
Рассмотрим изменение радиального градиента. Щёлкните на инструменте Oval (Овал) и нарисуйте эллипс. Залейте его стандартной радиальной черно-зеленой заливкой. Затем на панели инструментов выберите инструмент Gradient Transform (Изменение заливки). Щёлкните внутри эллипса. На нем появятся манипуляторы, управляющие градиентом (рис. 24).

При настройке радиального градиента манипулятор выглядит как окружность, которая отмечает границу цветового перехода. За ней находится только черный цвет. На окружности находятся три манипулятора, и еще один — в центре окружности. Перемещение центрального манипулятора сдвигает светлый блик. При перемещении квадратика блик вытягивается в эллипс. Нижний кружок служит для вращения этого вытянутого блика. Средний кружок перемещается к центру или от центра. Граница перехода при этом сжимается или расширяется, в результате переход становится более резким или более размытым.

Изменение линейного градиента осуществляется таким же образом. Отличие состоит в том, что мы видим прямые ручки а не кнопки-модификаторы.

Можно заблокировать градиентную заливку. Для этого при Выборе инструмента Paint Bucket (Ведро с краской), в разделе Options (Свойства) включите кнопку-модификатор Lock Fill (Блокировать заливку) и попробуйте изменить заливку. Указатель выглядит при этом, как ведро с замочком.

Копирование атрибутов заливки и обводки

При выделении обводки или заливки какого-либо контура ее атрибуты становятся текущими, и вы можете использовать их для создания новых контуров или присвоить готовым контурам с помощью чернильницы или ведра с краской.

Более удобный способ копирования атрибутов заливки и обводки предоставляет инструмент Dropper (Пипетка). Чтобы скопировать атрибуты, надо щелкнуть им на обводке или заливке контура-образца. При этом происходит автоматическое переключение на инструмент Ink Bottle (Чернильница) или Paint Bucket (Ведро с краской), и вы сразу же можете выполнять обводку или заливку других контуров. Копируется не только цвет, но и все остальные атрибуты: стиль и толщина обводки, тип заливки. У ведра с краской автоматически включается режим блокирования заливки, так что если блокировка не нужна, сначала отключите ее, а потом заливайте контур.

Цветовые модели, или палитры
До сих пор мы довольствовались цветами из стандартной палитры цветов. В большинстве случаев ее вполне хватает. Теперь научимся сами создавать новые цвета и записывать их в палитру. Однако прежде поговорим о цвете и способах его представления.

Цвета, которые вы видите на экране, образуются только у вас в глазу. На самом деле они представляют собой набор микроскопических точек красного, зеленого и синего цвета. Эти цвета называются базовыми. Точки одного цвета выстраиваются в растровые линии. Растровые линии каждого базового цвета располагаются под своим углом, чтобы точки не накладывались друг на друга.

Таким образом, любой цвет имитируется на экране всего тремя базовыми цветами. Чтобы описать цвет с помощью чисел, можно использовать разные модели представления, или палитры. Как правило, для представления цвета на экране используется палитра RGB. Ее название складывается из начальных букв базовых цветов: Red (красный), Green (зеленый), Blue (синий). Любой цвет в этой модели описывается тремя числами – яркостями этих цветов. Яркость каждого цвета может меняться от 0 до 255.

В полиграфии чаще всего используется цветовая модель CMYK, основанная на четырех базовых цветах: голубом (Cyan), пурпурном (Magenta), желтом (Yellow) и черном (Black). Но поскольку Flash предназначен для экранного просмотра, с,этой моделью он не работает.

Помимо RGB, Flash поддерживает цветовую модель HSB. В этой модели цвет определяется тремя параметрами: Hue (оттенок), Saturation (насыщенность) и Brightness (яркость).

Для графического представления цветов в этой модели используется цветовой круг. На его окружности отложены все чистые спектральные цвета: нулевому углу соответствует красный цвет, углу 120° - зеленый, 240° - синий. Между ними находятся цвета, которые можно получить смешиванием этих цветов: под углом 60° - желтый, 180° - голубой и 300° - малиновый. Таким образом, любой цвет прежде всего определяется оттенком, или цветовым тоном, который численно равен углу на цветовом круге.

Насыщенность отражает интенсивность цвета. Чем больше насыщенность, тем более броским становится цвет, тем ближе он к чистому спектральному цвету. При уменьшении насыщенности цвет становится более блеклым, приближаясь к серому или белому цвету (это зависит уже от яркости). На цветовом круге насыщенность достигает максимума на границе круга, а в его центре она равна нулю.

Яркость отражает количество света, проходящего через прозрачный цветовой объект. Чем больше яркость, тем светлее цвет, чем она меньше, тем цвет темнее. При нулевой яркости цвет становится черным.

Палитру HSB удобнее использовать для подбора цвета, так как она основана не на абстрактном цветовом составе, а на восприятии цвета человеком и поэтому интуитивно более понятна.

Еще один способ описания цвета, который используется в редакторе Flash, — эти задание тех же трех чисел, что и в палитре RGB, но в шестнадцатеричной системе счисления. В этой системе вместо десяти цифр шестнадцать: 10 обычных цифр из привычной нам десятичной системы и буквы от А до F, соответствующие числам от 10 до 15. Таким образом, для описания каждой базовой составляющей хватает двух цифр, так как максимальное число 255 будет записано как FF. В итоге все описание цвета будет состоять из шести цифр. Например, синий цвет со значением R = 10, G = 100, В = 255 будет записан как OA64FF. Этот способ описания цвета используется во многих HTML-документах и Web-страницах.

Глубина цвета

Глубина цвета означает, сколько битов памяти отведено на хранение информации о цвете каждого пиксела. Чем больше глубина цвета, тем больше оттенков можно отобразить. Так, в монохромном черно-белом изображении на каждый пиксел отводится только один бит: цвет может быть либо черным, либо белым.

В монохромном полутоновом изображении используется 8-битовая глубина цвета, она способна передать уже 28, или 256 оттенков цвета, от белого до черного. Для цветных изображений требуется еще больше памяти. Для цветовых моделей RGB и HSB на каждый пиксел требуется 8 х 3, то есть 24 бита (по 8 бит на каждую составляющую).

Существенную роль в передаче цвета играет также, сколько цветов способен передать сам дисплей, а это зависит от размеров видеопамяти компьютера (памяти, в которой хранится экранное изображение). Наибольшее распространение сейчас получили мониторы, которые могут работать в разных цветовых режимах и с разным разрешением.

Самая богатая палитра достигается при 24-битовой глубине цвета. Это так называемый режим True Color (Истинный цвет), при котором количество цветов может быть больше 16 миллионов. При выборе большего разрешения приходится жертвовать богатством цветовой палитры и выбирать палитру похуже. Такую палитру обеспечивает режим High Color (Высокоточный цвет), использующий 16-битовую глубину цвета. В этой палитре может быть до 65 536 цветов. При работе с градиентными заливками в этом режиме можно заметить ступеньки в цветовом переходе, а в остальном этот режим немногим уступает режиму True Color. И самая бедная палитра в режиме с 256 цветами. Есть еще режим с 16 цветами, но он используется крайне редко.

Создание нового цвета

Конечно, лучше всего использовать для фильма только «безопасные» web цвета, но если очень хочется, то можно создавать и собственные цвета или копировать их из импортированного изображения и записывать в палитру цветов.

Для создания цвета используется панель Mixer (Миксер), уже показанная на рис. 25.
Если щёлкнуть на вкладке Color Swatches, то откроется такая же палитра, что и при выборе цвета. Щёлкните на значке карандаша или ведра с краской в зависимости от того, какой цвет вы хотите задать. Под индикаторами находятся поля. С их помощью можно задавать цвета в системе RGB.
Самый простой, но самый грубый способ выбора цвета в панели Mixer (Миксер) — щелкнуть в нужном месте цветовой шкалы, которую вы видите справа панели. Далее вы можете точнее подобрать его передвигая ползунок яркости. 

Второй способ — численное задание цвета. Они лежат в диапазоне 0-255, 0 — минимальная яркость, 255 — максимальная.

Для любого цвета можно включить частичную прозрачность, чтобы сквозь него просвечивали нижележащие цвета, в том числе цвет фона. Для этого уменьшите значение Alpha (Альфа) с помощью одноименного ползунка. Альфа — это коэффициент непрозрачности цвета. При его значении, равном нулю, любой цвет становится совершенно прозрачным, при 100 % — совершенно непрозрачным. Однако прозрачность начинает проявляться только в том случае, если контур сгруппирован или лежит на другом слое, нежели нижележащие объекты. То есть программе должно быть ясно, что вы не собираетесь комбинировать несколько объектов, объединяя их или вырезая один из другого. В противном случае цвета с уменьшенным значением коэффициента непрозрачности прозрачны только относительно фонового цвета.

Создав новый цвет, вы сделаете его текущим и одновременно окрасите им выделенные контуры, если таковые есть. Если этот цвет понадобится вам при дальнейшей работе с фильмом, запишите его в палитру цветов. Для этого в меню панели щелкните на инструменте Fill Color (Цвет заливки) или Stroke Color (Цвет контура) и самую верхнюю правую кнопку. При этом откроется окно настройки цвета (рис. 26)
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Рис. 26: Добавление цвета
Здесь необходимо указать цвет, который мы хотим заменить (в поле дополнительные цвета), потом указать нужный нам цвет или ввести его цифровое значение в поля справа и нажать кнопку Добавить в набор. После этих операций выбранный нами цвет будет доступен для выбора. 
Урок 6. «Текстовые блоки»

Текстовые блоки
Существенной частью фильма может быть текст. Flash предоставляет довольно широкие возможности по редактированию и форматированию текста. Кроме того, что вы можете в любое время редактировать сам текст, у него можно менять атрибуты символов и абзацев, то есть назначать ему другие кегль, гарнитуру, выравнивание и т. д.

Текстовые блоки являются такими же объектами, как и графические элементы. Это значит, что вы можете вращать их, зеркально отражать, масштабировать, менять порядок их наложения на графические объекты и т. д. 
Текстовый блок может быть статическим, динамическим или полем ввода. Статический текст остается неизменным во все время своего существования. Текст в динамическом блоке может обновляться, загружаясь с сервера или вычисляясь с помощью сценариев по ходу проигрывания фильма. Поле ввода представляет собой текстовое поле, в которое зритель может вводить собственный текст, но мы это рассматривать не будем.

Для ввода текста служит инструмент Text (Текст). Текст всегда вводится в специальную прямоугольную рамку — текстовый блок. При вводе текста вы можете либо сразу задать ширину текстового блока, либо определить только точку начала текста.

В первом случае текст при вводе будет сам переходить со строки на строку по достижении правой границы блока. Такой блок используется чаще всего называют стандартным. Вы можете в любое время изменить ширину стандартного блока, текст внутри будет форматироваться автоматически, в соответствии с новой шириной блока. Для ввода больших массивов текста следует использовать именно такие блоки.

Во втором случае при вводе будет образовываться одна длинная строка. Для переноса текста на другую строку вам придется каждый раз самим нажимать клавишу Enter. Поэтому второй способ используется только для ввода коротких надписей, например, для текста, который затем преобразуют в контур. Такой блок всегда растягивается точно по длине самой длинной строки, поэтому он называется «резиновым».

Чтобы создать стандартный блок, нажмите кнопку мыши при выбранном инструменте Text (Текст) и тащите указатель вправо. За ним потянется узкая прямоугольная рамка. Когда она достигнет нужной ширины, отпустите кнопку мыши. Для создания «резинового» блока достаточно щелкнуть один раз в нужном месте сцены.

Подчеркнем еще раз, что текстовый блок, с одной стороны, является таким же объектом, как и графические объекты, поэтому над ним можно выполнять все те же действия. С другой стороны, он содержит текст, который можно редактировать и у которого можно менять атрибуты. Чтобы работать с блоком как с объектом, его следует выделять инструментом Arrow (Стрелка), а чтобы работать непосредственно с текстом, нужен инструмент Text (Текст).

Выберите инструмент Text (Текст). Указатель превратился в крестик с буквой А. В индикаторе заливки выберите черный или другой темный цвет. Этим цветом будут вводиться символы текста. Щелкните в любом месте страницы, здесь появится маленький прямоугольник, а внутри него мигающая вертикальная черточка — курсор. На его месте будут появляться символы, которые вы будете вводить на клавиатуре (рис. 27а)
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Рис. 27: Текстовые блоки

Введите несколько слов. Вы видите, что по мере ввода ширина блока увеличивается (рис. 27б). Разобьем надпись на две строки, чтобы сделать блок уже. Щелкните между словами, чтобы установить там курсор. Нажмите клавишу Enter. Все, что находилось правее курсора, «переходит» на новую строку, а ширина блока уменьшается (рис. 27в).

Чтобы, наоборот, соединить две строки и тем самым увеличить ширину блока, установите курсор в начале второй строки и нажмите клавишу Backspace. Можно также установить курсор в конце первой строки и нажать клавишу Del. Этим вы удалите невидимый символ перевода на новую строку.

Изменение размеров блока

В верхнем правом углу стандартного текстового блока вы видите квадратик. Это ограничитель блока. Чтобы изменить ширину блока, установите на него указатель (он превратится в двухстороннюю стрелку) и перетащите его вправо или влево. Высота блока изменится автоматически, чтобы поместился весь введенный в блок текст, но не было пустых строк. Для изменения размеров ранее введенного блока сначала щелкните внутри него инструментом Text (Текст).

Для изменения размеров «резинового» блока разбивайте или объединяйте его строки, как мы делали в упражнении ранее. Блок будем автоматически подгоняться под самую длинную из строк. Однако вы всегда можете превратить «резиновый» блок в стандартный. В его верхнем правом углу тоже находится ограничитель, но он выглядит, как кружочек. Установите указатель на него и перетащите вправо или влево, чтобы задать его новую ширину. Блок при этом автоматически поменяет свой тип. Чтобы наоборот, стандартный блок сделать «резиновым», дважды щелкните на его ограничителе.

Текстовые блоки удаляются так же, как графические объекты: выделите блок инструментом Arrow (Стрелка) и нажмите клавишу Del. Пустые блоки удаляются автоматически.
Выделение фрагментов текста

Создавая текст в фильме, вы можете либо заблокировать его, либо дать пользователю возможность выделять его и копировать в буфер обмена. Для того чтобы сделать текст доступным для выделения, выделите текстовый блок или щелкните внутри него инструментом Text (Текст), а затем установите флажок Selectable (Выделяемый) на панели Text Options (Параметры текста) (рис.28). Чтобы заблокировать текстовый блок, снимите этот флажок.
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Рис.28: Выделение фрагментов текста

Редактирование текста

Редактирование текста в системе Flash очень мало отличается от редактирования в том же редакторе Microsoft Word, поэтому лишь кратко «пробежимся» по основным приемам редактирования.

Чтобы выделить фрагмент текста, выберите инструмент Text (Текст), нажмите кнопку мыши на первом символе фрагмента и расширяйте выделяемый фрагмент вправо или вниз - словом, так, как это делается в Microsoft Word и других текстовых редакторах. После того как вы отпустите кнопку мыши, фрагмент останется выделенным, и вы сможете удалить его, скопировать, изменить атрибуты и пр. Чтобы снять выделение, щелкните в любом месте текста.

Чтобы выделить одно слово, достаточно дважды щелкнуть на нем. Для выделения больших кусков текста удобно щелкнуть мышью, нажать клавишу Shift и щелкнуть мышью еще раз. При этом выделяется весь текст между первым и вторым щелчками мыши.
Для редактирования атрибутов текста используется окно, показанное на рис. 28. Здесь можно установить шрифт текста, его начертание, кегль, словом, всё как вредакторе Microsoft Word.
Преобразование текста в контуры

Flash позволяет превратить текстовый блок в набор контуров, с которыми можно дальше работать, как с обычными кривыми Безье. Кстати, это единственный способ создать текст с градиентной заливкой. Для выполнения такого преобразования выделите текстовый блок инструментом Arrow (Стрелка) и выполните команду Modify ► Break Apart (Изменить ► Разбить) или воспользуйтесь сочетанием клавиш Ctrl + B.
Каждый символ преобразуется в отдельный контур с заливкой, но без обводки. Теперь вы можете окрашивать символы в разные цвета, а также создавать для них обводку с помощью чернильницы.

Если вы хотите удержать текст вместе, выделите все полученные контуры и сгруппируйте их клавишами Ctrl+G. После этого можно перемещать всю группу целиком, масштабировать, вращать и т. д. После преобразования текст больше нельзя редактировать и, более того, преобразовать эти контуры обратно в текст уже невозможно.

Для примера введем надпись и присвоим ей градиентную заливку (рис. 29).  Щелкните на сцене инструментом Text (Текст) и введите короткую надпись крупным кеглем. Выделите созданный блок инструментом Arrow (Стрелка) и выполните команду Modify ► Break Apart (Изменить ► Разбить). Причём отличие Flash 8 от предыдущих версий состоит в том, что последнюю команду следует выполнить дважды. Первый таз она разбивает текст на отдельные буквы, а второй буквы преобразует в контуры. Все полученные контуры необходимо выделить (если они не выделены) и помощью индикатора заливки выбрать готовый градиент, затем отредактировать его с помощью панели заливки. 
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Рис. 29: Градиентный текст
Обведите все буквы рамкой этим же инструментом и сгруппируйте надпись, нажав клавиши Ctrl+G. Теперь все буквы будут перемещаться вместе.

Текст, преобразованный в контуры, часто используется в качестве маски. Для того чтобы научиться это делать нам потребуется любой рисунок или фотография. Вставьте на сцену фотографию воспользовавшись меню Edit ► Paste in Center (Изменить ► Вставить в центр). Создайте новый слой (как это делается, рассматривалось в уроке 2). Введите на этом слое надпись крупным кеглем (рис. 30), Цвет надписи не играет роли. Щелкните правой кнопкой мыши на слое текста и выберите в контекстном меню команду Mask (Маска). Текст становится маскированным (рис. 30). Маска и маскированный слой автоматически блокируются. Нижний слой (на котором фотография) становится подложкой для верхнего.
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Рис.30: Текст на слое-маске
Чтобы сдвинуть надпись или отредактировать ее, разблокируйте слой-маску. Передвинув надпись или изменив форму ее контуров, снова заблокируйте слой-маску или выберите команду Show Masking (Показать маскирование) контекстного меню.
Урок 7. «Операции над объектами»

В программе Flash имеются объекты двух типов: текстовые и графические. К текстовым объектам относятся текстовые блоки, к графическим - векторные контуры и импортированные изображения. В этом уроке мы рассмотрим операции, которые выполняются совершенно одинаково со всеми видами объектов.

Для начала мы разберемся, как выполнять самые простые операции над объектами: удалять их, копировать, перемещать, группировать и блокировать. Однако, прежде чем выполнять операции над объектами, их надо выделить.

Выделение

Для выделения заливки надо щелкнуть внутри контура инструментом Arrow (Стрелка). Чтобы выделить всю обводку, дважды щелкните на любом ее сегменте. Для выделения контура целиком, то есть вместе с обводкой и заливкой, обведите его рамкой с помощью этого же инструмента или дважды щелкните внутри заливки.

Чтобы выделить сгруппированный контур, достаточно щелкнуть на его заливке или обводке. Для выделения импортированного изображения щелкните внутри него инструментом Arrow (Стрелка). Точно так же выделяются текстовые блоки, но надо попасть указателем не на пустое место блока, а на какой-нибудь символ.

Если операцию надо произвести над несколькими объектами сразу (окраска их одним цветом, перемещение, вращение, масштабирование и т. д.), надо выделить их все. Для этого второй и следующие объекты выделяйте при нажатой клавише Shift. Часто удобнее всего выделить несколько объектов, обведя их с помощью инструмента Arrow (Стрелка) или Lasso (Лассо). Чтобы выделить все, что нарисовано на слое, достаточно щелкнуть на имени слоя на панели слоев. При выделении нескольких объектов с помощью рамки или лассо следует проследить, чтобы несгруппированные контуры обязательно попали в рамку целиком. Если какие-то опорные точки контура или часть заливки туда не попадут, они не выделяются и при перемещении объектов остаются на месте.

Для того чтобы отменить выделение любого из нескольких выделенных объектов, щелкните на нем, держа нажатой клавишу Shift. Так вы сможете убрать из выделения лишний объект, попавший туда при выделении рамкой. Чтобы отменить выделение всех объектов, щелкните на пустом месте окна документа. Если пустого места в пределах видимости мало или нет вообще, можно вместо этого выполнить команду Edit ► Deselect All (Правка ► Снять все выделения).

При использовании всех описанных выше способов объекты выделяются сразу на всех видимых слоях. Если вы хотите защитить от изменений какие-то слои, заблокируйте их (см. урок 2). Объекты на блокированных слоях не выделяются.

Чтобы быстро выделить все объекты сцены, кроме тех, что находятся на невидимых и заблокированных слоях, нажмите клавиши Ctrl+A или выполните команду Edit ► Select All (Правка ► Выделить все).
Перемещение объектов
Для перемещения выделенных объектов выберите инструмент Arrow (Стрелка) или Lasso (Лассо), нажмите кнопку мыши на заливке или обводке одного из объектов и, держа нажатой кнопку мыши, перетащите его на новое место.

Если при перетаскивании объекта держать нажатой клавишу Shift, он будет перемещаться строго по вертикали, горизонтали или под углом 45° к горизонту.

На небольшие расстояния удобнее перемещать объекты с помощью клавиш-стрелок. Каждое нажатие клавиши-стрелки перемещает выделенные объекты на один пункт, при нажатой клавише Shift – на 8 пунктов.

При перемещении объектов вы можете использовать панель Info (Информация) как для получения информации, так и для точного перемещения. При выделении объекта в нижней части панели появляются поля, определяющие положение этого объекта (рис.31). 
Здесь вы видите информацию о размерах выделенного объекта и о его положении: W – ширина, Н – высота, X – координата по горизонтали, Y – координата по вертикали. По умолчанию даются координаты верхнего левого угла габаритной рамки объекта. В этих полях используются те же единицы измерения, что и на координатных линейках. Как сменить их, мы говорили в разделе «Координатные линейки» урока 2. Начало координат находится в верхнем левом углу сцены.

Для того чтобы поместить объект точно в заданном месте, введите нужные координаты в поля X и Y. Перемещение происходит, когда вы нажимаете клавишу Enter или щелкаете вне поля.
Удаление, копирование и вставка

Удалять объекты очень просто: выделите их все и нажмите клавишу Del или выполните команду Edit ► Clear (Правка ► Очистить).

Есть два способа копировать объекты. Первый — когда копия нужна где-то рядом. Выделите объект и выполните команду Duplicate (Дублировать) меню Edit (Правка). Вы получите копию чуть ниже и правее исходного объекта. Копия уже будет выделена, так что вы тут же можете перетащить ее в другое место.

Кроме того, можно дублировать объекты с помощью мыши. Выделите объект и перетащите его на новое место, держа нажатой клавишу Alt. При этом вы перетаскиваете копию, а сам объект остается на месте. Если вы создаете много копий, можете вообще не отпускать эту клавишу.

Второй способ – копирование объекта в буфер обмена, чтобы затем вставить его в другом фильме, в другой сцене или в другом кадре. Для этого выделите нужный объект (или несколько объектов) и нажмите клавиши Ctrl+C или выполните команду Edit ► Сору (Правка ► Копировать). Теперь можете открыть другой фильм или перейти в другое место того же фильма и вставить там копию объекта клавишами Ctrl+V или командой Edit ► Paste (Правка ► Вставить). Копия будет вставлена в центре окна. Чтобы вставить ее на том же месте сцены, используйте клавиши Ctrl+Shift+V или команду Edit ► Paste in Place (Правка ► Вставить на месте).

Этот же способ можно использовать, чтобы копировать контуры и текст между разными приложениями. При переносе текста из текстовых редакторов он вставляется в виде группы «резиновых» текстовых блоков: каждая строка в отдельном блоке. Если вместо команды Сору (Копировать) использовать команду Cut (Вырезать), копия объекта останется в буфере обмена, но сам объект со страницы исчезнет – вы его вырезаете. Этой команде соответствует нажатие клавиш Ctrl+X.

Вместо команд меню можно пользоваться соответствующими кнопками основной панели инструментов.
Группировка

Нарисовав несколько контуров, которые составляют одно изображение и поэтому не должны менять взаимного расположения, объедините их в группу. Для этого выделите их и нажмите клавиши Ctrl+G или выполните команду Modify ► Group (Изменить ► Сгруппировать). Сгруппировать можно только объекты с одного слоя. При выполнении этой операции над объектами с разных слоев для каждого слоя создается отдельная группа.

Для того чтобы разбить группу, используется команда Modify ► Ungroup (Изменить ► Разгруппировать). Группа может быть вложенной, то есть содержать другие группы. При выполнении каждой команды Ungroup (Разгруппировать) группы разбиваются поочередно, в порядке вложенности.

Для редактирования объектов группы или для перемещения их друг относительно друга необязательно разбивать группу. Дважды щелкните на одном из объектов группы инструментом Arrow (Стрелка). Все, кроме группы, блокируется и никак не мешает редактированию. При этом только объекты группы сохраняют свой исходный цвет, все остальное становится более блеклым.

Далее вы можете редактировать объекты группы точно так же, как обычно. Окончив работу, дважды щелкните на пустом месте или выполните команду Edit ► Edit All (Правка ► Редактировать все).

Если вы решили, что какие-либо объекты окончательно нашли свое место на сцене и вряд ли будут меняться, лучше всего сгруппировать их, а группу заблокировать, чтобы она не мешала работать с другими объектами. Для этого выделите группу и выполните команду Modify ► Arrange ► Lock (Изменить ► Расположить ► Блокировать). После этого группу нельзя будет выделить никаким из вышеописанных способов.

Хотя вы можете блокировать новые группы по одной, снять блокировку можно только для всех групп сразу. Для этого выполните команду Modify ► Arrange ► Unlock All (Изменить ► Расположить ► Разблокировать все).

Трансформация объектов

К трансформации объектов относятся масштабирование, то есть изменение размеров, вращение, зеркальное отражение и перекос, то есть наклон вдоль осей координат. 

Для вызова панели трансформации (рис. 32) выполните команду Window ► Panels ► Transform (Окно ► Панели ► Трансформация). Чтобы выполнить трансформацию, надо ввести коэффициент масштабирования, угол поворота или перекоса и нажать клавишу Enter. Работая с панелью, можно достичь большей точности. Однако это не так наглядно, и часто удобнее отредактировать объект «на глаз» от руки.

 Впрочем, даже выполняя перемещение или трансформацию объектов вручную, вы можете использовать панель трансформации для отслеживания изменений и для повторения проделанной операции. Любое ваше действие с манипуляторами трансформации тут же отражается в соответствующем поле панели.

Внизу панели трансформации вы видите две кнопки. Левая кнопка Copy and Apply Transform (Копировать и трансформировать) выполняет заданную трансформацию не над самим объектом, а над его дубликатом. Правая кнопка Reset (Вернуть) отменяет все трансформации, возвращая объекту исходный вид.
Начнем с изменения размеров объекта вручную. Выделите его инструментом Arrow (Стрелка) и щелкните на кнопке-модификаторе Scale (Масштаб) или выполните команду Modify ► Transform ► Scale (Изменить ► Трансформация ► Масштаб) или щёлкните на соответствующей кнопке в панели Options (Свойства). Вокруг объекта появится рамка с манипуляторами трансформации. Перетаскивая манипулятор на середине любой стороны, вы изменяете размер объекта только по вертикали или горизонтали. Если перетаскивать угловой манипулятор, изменяются одновременно оба размера. Чтобы сохранить пропорции объекта, при перемещении углового манипулятора держите нажатой клавишу Shift.

Когда указатель оказывается внутри объекта, он принимает вид указателя перемещения, так что вы можете передвинуть объект, не выходя из режима масштабирования. Щелкнув внутри другого объекта, вы сразу же выделяете его в режиме масштабирования. Закончив редактирование всех объектов, щелкните на пустом месте окна, чтобы манипуляторы исчезли.

Если перед выполнением операции масштабирования выделить сразу несколько объектов, то вокруг них появится единая невидимая рамка с манипуляторами трансформации и вы сможете трансформировать эти объекты как единое целое.

Для точного задания размеров  откройте панель Info (Информация) (рис. 33), введите в поле W нужное значение общей ширины объекта или выделенных объектов, например 160 пикселов, и нажмите клавишу Enter.
Вращение, зеркальное отражение
Вы можете вращать любой объект по часовой стрелке или против нее на угол в пределах 360°. Это можно сделать как вручную, с помощью инструмента Arrow (Стрелка)  введя значение угла вращения на панели трансформации. Положительные значения углов поворачивают объект по часовой стрелке, отрицательные – против.

Можно поворачивать объекты и вручную. Для этого необходимо воспользоваться инструментом Free Transform (Изменение). Манипуляторы в углах рамки служат для вращения, манипуляторы в серединах сторон - для масштабирования. Чтобы поворот производился с шагом, кратным 45°, при перетаскивании манипулятора держите нажатой клавишу Shift.

Для групп, объектных символов, текстовых блоков и импортированных изображений (короче, для всех типов объектов, кроме обычных контуров) вращение выполняется относительно точки регистрации, которая по умолчанию находится в центре объекта. Ее достаточно просто перенести. Для этого надо выделить объект и просто перенести белый кружок, находящийся в центре в любое место. Flash запомнит местоположение точки регистрации, и все последующие трансформации будет выполнять относительно нее. Чтобы вернуть точку регистрации на «законное» место в центре, дважды щелкните на ней.

Чтобы быстро повернуть выделенный объект на 90°, достаточно выполнить команду Rotate 90° CW (Повернуть на 90° по часовой стрелке) или Rotate 90° CCW (Повернуть на 90° против часовой стрелки) из меню Modify ► Transform (Изменить ► Трансформация)
Объект можно зеркально отразить по вертикали или горизонтали. Делается это буквально одной командой. Команда Modify ► Transforn ► Flip Vertical (Изменить ► Трансформировать ► Отразить вертикально) отражает объекты по вертикали, а команда Flip Horizontal (Отразить горизонтально) из того же подменю – по горизонтали. 

Перекос

Перекосить объект вдоль оси координат – это наклонить его вдоль этой оси, оставив «ноги» на месте. Угол перекоса – угол между осью симметрии объекта и перпендикуляром к оси координат. Перекашивать можно по горизонтальной оси, по вертикальной оси или одновременно по двум осям.

Вручную перекос выполняется в том же режиме, что и вращение, но теперь вам понадобятся манипуляторы между серединой и углом стороны габаритной рамки. Манипуляторы сверху и снизу перекашивают объект по горизонтали, а манипуляторы по бокам - по  вертикали.

Чтобы перекосить объект более точно, на панели трансформации выберите переключатель Skew (Перекос) и введите угол перекоса по горизонтали в левое поле, а по вертикали – в правое и нажмите клавишу Enter. Как и при вращении, вы можете создать серию дубликатов объекта с разными углами перекоса, щелкая на кнопке Copy and Apply Transform (Копировать и трансформировать).

Порядок наложения объектов

При создании объектов на одном слое новый объект всегда накладывается поверх старых, как карты в колоде. Это не относится только к несгруппированным контурам, которые всегда лежат в одной плоскости, которая находится ниже всех групп, символов, импортированных изображений и текстовых блоков слоя. Для всех остальных типов объектов можно менять порядок наложения их друг на друга в любое время. Чтобы иметь возможность делать это для всех рисованных контуров, лучше всего группировать их сразу после создания.

В простых случаях для достижения нужного порядка достаточно перенести один из объектов на самый верх или на самый низ «колоды» или поменять его местами с соседом снизу или с соседом сверху. Для этого надо выделить его и выполнить одну из команд подменю Arrange (Разместить) меню Modify (Изменить):

· Bring To Front (Выдвинуть на передний план) – перенести объект на передний план;

· Send to Back (Задвинуть на самый низ) – перенести объект на задний план;

· Bring Forward (Передвинуть вперед) – поменять с соседом сверху;

· Send Backward (Передвинуть назад) – поменять с соседом снизу.

В более сложных случаях вам придется выполнить серию перестановок.

Все описанные выше команды действуют только в пределах одного слоя. Объекты, расположенные на разных слоях, располагаются в том же порядке, что и сами слои. Чем выше слой в панели слоев, тем выше его объекты в стопке. Чтобы поменять местами объекты, надо поменять местами сами слои. При этом поднимаются или опускаются сразу все объекты слоя, порядок наложения их внутри слоя не меняется.

Выравнивание

При создании рисунка вам может понадобиться выровнять объекты по одной линии или расположить их на равном расстоянии друг от друга. Это делается с помощью панели Align (Выравнивание), показанной на рис. 34. Эту панель можно вызвать клавишами Ctrl+K, командой Window ► Panels ► Align (Окно ► Панели ► Выравнивание) или кнопкой из основной панели инструментов.
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Рис.34. Панель выравнивания

Для выравнивания объектов служит верхний ряд кнопок Align (Выравнивать):

· Align Left Edge (Выравнивать левый край) – левые  края всех объектов выравниваются по левому краю крайнего слева объекта;

· Align Horizontal Center (Выравнивать центр по горизонтали) – по одной линии выравниваются вертикальные оси всех объектов;

· Align Rig-ht Edge (Выравнивать правый край) – правые края всех объектов выравниваются по правому краю крайнего справа объекта;

· Align Top Edge (Выравнивать верхний край) – верхние края всех объектов выравниваются по верхнему краю самого верхнего объекта;

· Align Vertical Center (Выравнивать центры по вертикали) – по одной линии выравниваются горизонтальные оси всех объектов;

· Align Bottom Edge (Выравнивать нижний край) – нижние края всех объектов выравниваются по нижнему краю самого нижнего объекта.

Второй ряд кнопок Distribute (Распределить) равномерно распределяет объекты по вертикали или горизонтали между крайними объектами, которые во всех случаях остаются на месте. Расчет ведется по соответствующим краям объектов:

· Distribute Top Edge (Распределить по верху) – по верхушкам объектов;

· Distribute Vertical Center (Распределить центры по вертикали) – по их центрам относительно вертикали;

· Distribute Bottom Edge (Распределить по низу) – по нижним краям;

· Distribute Horizontal Center (Распределить центры по горизонтали) — по их центрам относительно горизонтали;

· Distribute Right Edge (Распределить по правому краю) – по правым краям.

Две кнопки в разделе Space (Промежутки) распределяют объекты так, чтобы между ними были одинаковые промежутки:

· Space Evenly Vertically (Распределить равномерно по вертикали) – по вертикали;

· Space Evenly Horizontally (Распределить равномерно по горизонтали) – по горизонтали.

Три кнопки раздела Match Size (Подогнать по размеру) масштабируют объекты так, чтобы у них была одинаковая ширина, высота или и то и другое. За образец берется самый широкий или самый высокий объект.

Обратите внимание на кнопку То Stage (По сцене) в правой части окна. Если она включена, то выравнивание и распределение производится не относительно крайних объектов, а относительно самой сцены.

Урок 8. «Анимация»

Принципы анимации в программе Flash такие же, как в мультипликации. Имеется последовательность кадров, каждый из которых немного отличается от предыдущего. При быстрой смене кадров на экране создается впечатление движения, плавного изменения размера, формы или цвета.

Есть два способа создания анимации. Первый способ – покадровая анимация, когда вы рисуете все кадры подряд, постепенно их видоизменяя. Это не слишком рациональный способ анимации и в смысле затраченного времени, и в смысле размеров файла, поэтому он используется редко, только в тех местах фильма, где происходят быстрые резкие изменения. Второй способ – промежуточная анимация, когда вы задаете начальное и конечное состояния объекта в ключевых кадрах, a Flash рисует объект в промежуточных кадрах.

Промежуточная анимация может быть анимацией движения и анимацией форм (морфингом). Анимация движения состоит в том, что объект трансформируется, перемещается и (или) меняет цвет и прозрачность, и выполняется она только над объектными символами. Морфинг состоит в том, что контуры меняют свою форму, и выполняется он только над несгруппированными контурами.
Временная линейка

Основным инструментом при работе с анимацией является временная линейка (рис. 35). Она слита воедино с панелью слоев, поскольку для каждого слоя кадры задаются независимо или, если посмотреть на это с другой стороны, отдельный кадр может состоять из множества слоев. В дальнейшем, когда мы будем говорить о выделении кадров, почти всегда будет иметься в виду кадр для какого-либо определенного слоя, а не вообще кадр.

Сверху на временной линейке отложены деления. Это номера кадров. Там же находится ползунок в виде красного квадрата с вертикальной чертой. Это головка воспроизведения. Она отмечает текущий кадр. При проигрывании фильма она сама движется от начального кадра к конечному. При работе над фильмом вы можете перемещать ее, перетаскивая или просто щелкая на нужном кадре.
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Рис.35: Временная линейка

Если фильм длинный, быстро найти головку вам поможет кнопка Center Frame (Центрировать кадр) внизу временной линейки. Она прокручивает фильм так, чтобы головка вместе с текущим кадром оказалась в центре видимой части линейки.

В анимации есть несколько типов кадров. Самые важные – ключевые кадры. Они определяют содержание фильма. Вы можете рисовать в них или импортировать объекты, редактировать их, трансформировать или перемещать. Ключевые кадры отмечаются на линейке черными кружочками. За ключевым кадром могут идти обычные, или статические, кадры. Они содержат ровно то же самое, что и ключевой кадр. Все, для чего они нужны, это показывать на экране ключевой кадр заданное время. Чем дольше должен длиться ключевой кадр, тем больше статических кадров надо создать в его «хвосте». Статические кадры серого цвета, последний кадр в «хвосте» отмечается полым прямоугольником. Если нарисовать что-либо в статическом кадре или вставить в него экземпляр символа, нарисованное окажется на ближайшем слева ключевом кадре.

Ключевой кадр может быть пустым, если объект слоя еще не появился в фильме или уже исчез. Пустые ключевые кадры отмечаются вертикальной линией перед кадром. Статические кадры, идущие за пустым ключевым кадром, тоже пусты. В отличие от заполненных статических кадров они белого цвета.

Промежуточные кадры между ключевыми кадрами вычисляются самой программой, так что редактировать их нельзя. Эти кадры отмечаются либо голубым цветом, либо зеленым. Голубой цвет - это анимация движения, зеленый – анимация форм. От одного ключевого кадра к другому идет черная стрелка.

Щелкнув на кнопке в верхнем правом углу временной линейки, вы вызовете меню, управляющее ее внешним видом. В верхнем разделе можно задать ширину ячейки, отведенной для одного кадра: Tiny (Крошечная), Small (Маленькая), Normal (Нормальная), Medium (Средняя), Large (Большая). Работать удобнее всего с большими или нормальными ячейками, а вот для того чтобы увидеть весь длинный фильм, можно выбрать маленькие или даже крошечные ячейки.

Следующий пункт меню Short (Короткий) позволяет немного уменьшить высоту ячеек. Это удобно, когда в фильме больше пяти слоев. По умолчанию включен режим Tinted Frames (Окрашенные кадры), когда кадры разных типов выделяются разным цветом. Если убрать галочку у этой команды, все кадры будут одного цвета.

Выбрав режим Preview (Предварительный просмотр), вы увидите миниатюрные изображения объектов в ключевых кадрах каждого слоя прямо на временной линейке. Все миниатюры одного и того же размера, независимо от истинных размеров объектов. В режиме Preview in Context (Просмотр в контексте) вы также увидите миниатюры объектов, но уже с соблюдением пропорций.

Калька

При редактировании анимации вам может пригодиться режим, когда на сцене одновременно видны нескольких соседних кадров. Для включения этого режима щелкните на кнопке Onion Skin (Калька) (рис. 36а) внизу временной линейки. Текущий кадр вы будете видеть в полном цвете и сможете редактировать его, а соседние кадры будут видны, как в тумане, и редактировать их будет нельзя (рис. 36б).
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Рис.36: Режим кальки
На рис. 36а снизу обведены те самые кнопки-модификаторы: Onion Skin (Калька), Onion Skin Outlines (Контуры на кальке)и кнопка Modify Onion Markers (Изменить маркеры кальки).
 Чтобы соседние кадры не мешали редактированию текущего кадра, можно включить режим, в котором соседние кадры будут видны только в виде контуров (рис. 36в). Для этого щелкните на соседней кнопке Onion Skin Outlines (Контуры на кальке). На каждом слое используется свой цвет контуров, чтобы вам было легче отличать объекты одного слоя от объектов другого слоя.

Щелкнув на кнопке Edit Multiple Frames (Редактировать несколько кадров), вы сможете не только видеть одновременно несколько кадров, но и редактировать их. Все кадры показываются совершенно одинаково, в цвете. Заблокированные слои в режиме кальки не видны. Поэтому чтобы при просмотре или редактировании вам не мешали лишние объекты, заблокируйте слои, на которых они находятся.

 Взгляните на головку воспроизведения. При включении любого режима кальки с двух сторон от нее появляются маркеры кальки (рис. 36а). Они отмечают начало и конец видимого диапазона кадров. Вы можете управлять этим диапазоном, перемещая маркеры кальки. Левый и правый маркеры перемещаются независимо, так что можно видеть, например, только кадры, предшествующие текущему кадру или только следующие за ним. Для перемещения маркера нажмите на нем кнопку мыши и перетащите влево или вправо.

Щелчок на кнопке Modify Onion Markers (Изменить маркеры кальки) вызывает меню, управляющее настройкой маркеров. Команда Always Show Markers (Всегда показывать маркеры) включает показ маркеров кальки даже в том случае, если ни один из режимов кальки не включен. Выбрав команду Anchor Onion (Закрепить кальку), вы заблокируете кальку в заданном состоянии. При перемещении головки воспроизведения маркеры не будут перемещаться вместе с ней, а останутся на месте.

В этом же меню можно быстро задать ширину диапазона 5 и 11 кадров, выбрав, соответственно, команду Onion 2 (Калька 2) или Onion 5 (Калька 5). Команда Onion All (Калькировать все) будет показывать одновременно все кадры фильма.

Метки кадров и комментарии

При создании достаточно больших фильмов помимо сцен удобно использовать и метки кадров. Чтобы поставить метку щелкните на нужном ключевом кадре в соответствующем слое и введите метку в поле Label (Метка) в появившемся меню снизу экрана, как показано на рис. 37. Метки сохраняются при публикации фильма, поэтому лучше избегать длинных меток.
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Рис. 37: Назначение метки кадру

Вместо меток можно вводить комментарии к ключевым кадрам, чтобы потом было легче вспомнить, что должно происходить в данном ключевом кадре. Комментарий вводится в то же самое поле, но перед ним надо поставить две прямые наклонные черты (//). Комментарий не сохраняется при публикации фильма, поэтому он может быть достаточно длинным.

Метки и комментарии видны на временной линейке. Метки помечаются красным флажком, комментарии – зелеными наклонными чертами. На рис. 38 слева находится метка, справа – комментарий. 
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Рис.38: Метки и комментарии
Просмотр и тестирование фильма

При создании анимации вы должны время от времени смотреть, что у вас получается. Есть несколько способов сделать это. Самый простой способ – просмотреть прямо в среде разработки текущую сцену, нажав клавишу Enter. Сначала проигрывается фрагмент фильма от текущего кадра до конца, а при следующем нажатии этой клавиши сцена автоматически прокручивается на начало, и вы видите ее целиком. Кроме того, можно пользоваться для прокрутки фильма и для его просмотра в среде разработки панелью Controller (Проигрыватель), показанной на рис. 39. Для ее вызова выполните команду Window ► Toolbars ► Controller (Окно ► Панели инструментов ► Проигрыватель). 
Слева направо в проигрывателе идут кнопки Stop (Стоп), Rewind (Прокрутить в начало), Step Back (На кадр назад), Play (Проиграть), Step Forward (На кадр вперед), Go to End (Перейти в конец). Одноименные команды есть в меню Control (Управление). По умолчанию все эти команды и кнопки работают только в пределах текущей сцены. Чтобы включить режим просмотра всех сцен фильма, выполните команду Control ► Play All Scenes (Управление ► Проигрывать все сцены). В этом режиме порядок появления кадров на экране такой же, как при публикации, то есть сначала проигрываются все кадры первой сцены, потом все кадры второй сцены и т. д.

По умолчанию анимация проигрывается только один раз. Режим циклического просмотра включается командой Control ► Loop Playback (Управление ► Циклическая отмотка). В этом режиме по окончании анимации она автоматически прокручивается назад и показывается снова и снова, пока вы не щелкнете на кнопке Stop (Стоп) или не нажмете клавишу Esc.

Чтобы выполнить полноценное тестирование фильма, нажмите клавиши Ctrl+Enter или выполните команду Control ► Test Movie (Управление ► Тестировать фильм). Эта команда публикует фильм с текущими установками публикации, помещает полученный SWF-файл в ту же папку, что и авторский фильм, а затем показывает его в отдельном окне в среде тестирования с помощью программы Flash Player. Эта же программа используется для просмотра публикаций в браузерах.

Если вы хотите протестировать только текущую сцену, нажмите клавиши Ctrl+Alt+Enter или выполните команду Control ► Test Scene (Управление ► Тестировать сцену). При этом создается публикация только текущей сцены. Она также записывается в одну папку с авторским фильмом, и ей дается имя, составленное из имен фильма и сцены, например, test_Scene l.swf.

Кроме того, у вас есть возможность просмотреть и протестировать фильм непосредственно в браузере. Для этого нажмите клавишу F12 или выполните команду File ► Publish Preview ► Flash (Файл ► Предварительный просмотр публикации ► Flash). Откроется браузер, установленный на вашем компьютере, а в нем уже будет загружен только что созданный SWF-файл.
Работа с кадрами

Работая с временной линейкой, вы можете вставлять, удалять и перемещать ключевые и статические кадры. Кадры можно перемещать либо в другую позицию на временной линейке в пределах одного слоя, либо на другой слой. Оба типа кадров можно копировать в буфер обмена и вставлять оттуда. Ключевые кадры можно превращать в статические и наоборот.

Выделение кадров

Чтобы выделить один кадр какого-либо слоя, щелкните на нем. Таким образом вам удастся выделить ключевой или пустой кадр, а также статический или промежуточный кадр, предшествующий ключевому кадру. При щелчке на статическом кадре из середины «хвоста» или на промежуточном кадре анимации не будет выделена целая последовательность кадров, как в предыдущих версиях Flash, а выделиться только один статический кадр. Чтобы выделить последовательность кадров дважды щёлкните в любой статический кадр «хвоста» ключевого кадра.

Среди пустых кадров легко выделить целый диапазон кадров. Для этого нажмите кнопку мыши на крайнем из них и протащите указатель до другого края нужного диапазона. Чтобы выделить несколько ключевых кадров или заполненных статических, щелкайте на каждом из них при нажатой клавише Ctrl, чтобы не выделялась вся последовательность.

Вставка кадров

Чтобы вставить один или несколько статических кадров в конце фильма, щелкните на временной линейке в пустом кадре и нажмите клавишу F5 или выполните команду Insert ► Frame (Вставить ► Кадр). Весь промежуток от последнего ключевого кадра до указанного места будет заполнен статическими кадрами. Эту же команду можно найти в контекстном меню, если щелкнуть на месте вставки правой кнопкой мыши.

Есть еще один способ создавать статические кадры в конце фильма. Если последним в слое является ключевой кадр, перетащите его вправо при нажатой клавише Alt. Если же последним является статический кадр (он отмечен полым прямоугольником), надо перетащить вправо его.

Чтобы вставить статический кадр в середине фильма, щелкните в месте вставки правой кнопкой мыши и выберите в контекстном меню команду Insert Frame (Вставить кадр). Если надо вставить сразу несколько кадров, выделите нужное количество кадров в месте вставки и используйте ту же команду. Все соседние кадры справа от места вставки пододвинутся, и фильм удлинится.

Для вставки ключевого кадра в конце фильма выделите пустой кадр и нажмите клавишу F6 или F7. Этот кадр станет ключевым, а между ним и концом фильма будут вставлены статические кадры, повторяющие последний ключевой кадр.
Преобразование кадров

Если вы хотите превратить статический кадр в ключевой, выделите его и нажмите клавишу F6 или выполните команду Insert ► Keyframe (Вставить ► Ключевой кадр). В зависимости от того, каким был статический кадр, образуется заполненный или пустой ключевой кадр. Если же вы хотите создать пустой ключевой кадр на месте заполненного статического, используйте клавишу F7 или команду Insert ► Blank Keyframe (Вставить ► Пустой ключевой кадр). Все статические кадры справа от него также опустеют вплоть до следующего ключевого кадра.

Для некоторых целей вам может понадобиться превратить промежуточную анимацию в покадровую. Для этого все промежуточные кадры надо тоже превратить в ключевые. Выделите всю последовательность кадров анимации и выполните команду меню Modify ► Frames ► Convert to Key Frames (Изменить ► Кадры ► Преобразовать в ключевые кадры).

Чтобы преобразовать все выделенные кадры в пустые ключевые кадры, используйте команду Convert to Blank Key Frames (Изменить ► Кадры ► Преобразовать в пустые ключевые кадры) того же меню.

Если вы хотите, наоборот, превратить ключевой кадр в статический, щелкните на нем и выполните команду Insert ► Clear Keyframe (Вставить ► Очистить ключевой кадр). Ключевой кадр становится копией соседнего слева статического кадра, а вместе с ним и его «хвост» из статических кадров.
Удаление и перемещение кадров

Для удаления обычного или ключевого кадра, а также последовательности кадров, выделите их и нажмите клавиши Shift+F5 или выполните команду Insert ► Remove Frame (Вставить ► Удалить кадр). При удалении кадров общая продолжительность фильма уменьшается.

Для перемещения ключевого кадра или последовательности кадров выделите их и перетащите на другое место. При перемещении ключевого кадра его «хвост» из статических или промежуточных кадров становится длиннее или короче. Это происходит за счет «хвостов» соседних ключевых кадров, так что общая продолжительность фильма не меняется. Поэтому ключевой кадр можно перемещать, пока он не «уткнется» в соседний ключевой кадр.

При перемещении последовательности кадров она замещает собой те кадры, поверх которых ее поместили, а на ее старом месте создаются пустые статические кадры. Последовательность кадров можно перемещать как по шкале времени, так и по слоям. При переносе ее на другой слой туда переносятся все ее объекты из этих кадров.

«Хвост» из статических кадров можно удлинять или укорачивать, перетаскивая последний статический кадр, помеченный полым прямоугольником. Удлинение «хвоста» производится за счет соседней справа последовательности (ее крайний слева ключевой кадр двигается вправо, пока не «уткнется» в следующий ключевой кадр). Если справа расположены пустые статические кадры, то они просто замещаются статическими заполненными.
Копирование кадров

Чтобы перенести копию ключевого кадра или последовательности на другой слой или на другое место временной линейки, перетащите их при нажатой клавише Alt.

Выделив ключевой кадр или последовательность кадров, вы можете скопировать их в буфер обмена командой Edit ► Copy Frames (Правка ► Копировать кадры). Команда Edit ► Cut Frames (Правка ► Вырезать кадры) удаляет выделенные кадры и помещает их в буфер обмена.

Скопировав кадры в буфер обмена, щелкните в месте вставки и выполните команду Edit ► Paste Frames (Правка ► Вставить кадры). Этим способом кадры можно переносить как внутри одного фильма, так и в другие фильмы. Соседние кадры после вставки пододвигаются вправо, и длительность фильма увеличивается. Если перед вставкой выделить ключевой кадр (или последовательность кадров), то он (они) будет заменен копией последовательности из буфера.
Поворот анимации вспять

Для любой анимации, промежуточной или покадровой, можно поменять направление. Для этого выделите всю последовательность ее кадров, щелкните на любом из выделенных кадров правой кнопкой мыши и выберите в контекстном меню команду Reverse Frames (Обратить кадры). Ключевые кадры анимации поменяют свой порядок на обратный: последний станет первым, первый — последним. То же самое можно сделать с помощью команды Modify ► Frames ► Reverse (Изменить ► Кадры ► Обратить).

Эту возможность можно использовать, чтобы имитировать колебательные движения, например, маятника. Выполните анимацию движения маятника в одну сторону, затем выделите все кадры анимации, скопируйте и вставьте их в конец фильма. Вам останется только повернуть вспять вставленные кадры, и анимация готова.

Покадровая анимация

Покадровая анимация состоит только из ключевых кадров. Для ее создания вы рисуете кадры по одному, каждый раз добавляя новый ключевой кадр командой Insert Keyframe (Вставить ключевой кадр) или клавишей F6. Новый ключевой кадр повторяет содержание предыдущего кадра. После его редактирования вы создаете новый ключевой кадр, и так до конца анимации. 
Разберём это на примере. Выберите инструмент Oval (Овал) и нарисуйте винт (рис.40а). Для этого надо нарисовать один круг и 4 овала. Если вы нарисовали все это без обводки, то получившаяся фигура автоматически стала единой. Если нет, то выберите инструмент Arrow (Стрелка), выбелите все фигуры и сгруппируйте их, используя клавиши Ctrl + G. 
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Рис. 40: Покадровая анимация

Теперь создадим анимацию. Нажмите клавишу F6. при этом на временной линейке появится второй кадр и станет текущим. Пока он в точности такой же, как первый кадр. Инструментом Arrow (Стрелка) выделите наш объект. Выберите Free Transform (Изменение) и в поле Rotate (Поворот) укажите число 5.
Далее создайте ещё несколько кадров таким же образом, в каждом поворачивая наш объект. Включите режим одновременного просмотра или редактирования нескольких кадров, щелкнув на кнопке Onion Skin (Калька) или Edit Multiple Frames (Редактировать несколько кадров) (рис.40б). Для передачи ускоренного движения они должны становиться больше с каждым кадром. Нажмите клавишу Enter, чтобы увидеть анимацию в действии. 

Как видите, создание даже такой маленькой покадровой анимации довольно хлопотное дело. К тому же каждый кадр заметно увеличивает размеры файла. Поэтому покадровая анимация используется только в местах резких перемещений или изменений объекта. Чаще всего ее применяют для создания совсем коротких клипов, всего из двух-трех кадров. Такой циклически повторяющийся клип хорошо изображает быстрое вращательное или колебательное движение, например, пропеллер самолета, маятник часов и т. д. 
Анимация движения

Анимация движения применима только к символам, группам и текстовым блокам. В анимации движения имитируется не только движение объекта, как следует из названия, но и изменение размеров, вращение, перекос.
Возьмите инструмент Rectangle (Прямоугольник) и нарисуйте квадрат. Теперь на временной линейке отступите 30 кадров и, нажав правой кнопкой мыши, выберите Insert KeyFrame (Вставить ключевой кадр). 

Далее надо его изменить. Квадрат мы масштабируем, поворачиваем на 45 градусов по часовой стрелке и окрашиваем в другой цвет. Как это делается, мы рассматривали раньше.

Теперь щелкните на первом кадре слоя и выполните команду Insert ► CreateMotion Tween (Вставить ► Создать анимацию движения). По всей полосе кадров протягивается пунктирная линия, а сами кадры окрасятся в синий цвет. В нижнем меню в поле Tween  (Движение) выберите Shape (Рис. 41). Нажмите клавишу Enter для просмотра анимации. 
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Рис.41: Выбор типа движения
Включите режим одновременного просмотра или редактирования нескольких кадров, щелкнув на кнопке Onion Skin (Калька) или Edit Multiple Frames (Редактировать несколько кадров) (рис.42).
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Рис.42: Результат анимации

Серия движений

При анимации непрерывного движения, с разными ускорениями или траекториями можно использовать два пути. Первый – последовательное добавление новых анимаций в «хвост» старым. Конечный ключевой кадр старой анимации делается начальным кадром для следующей анимации. Удобнее всего организовать это так: задать режим Motion (Движение) для последнего ключевого кадра, а затем просто создавать новые ключевые кадры нажатием клавиши F6. Для всех них уже будет задана анимация движения, но со стандартными параметрами, так что вам придется подправить их в случае необходимости.

Второй путь – создание всей анимации от начального до конечного положения объекта и последующее разбиение ее на несколько участков. Для разбиения анимации достаточно создать внутри нее ключевые кадры и передвинуть на них объект в нужные места.
Создадим анимацию движения. Выберите инструмент Oval (Овал) и нарисуйте круг. Пересеките его двумя линиями так, как показано на рис. 43, удалите лишние линии и раскрасьте нужными цветами. Теперь создайте новый слой и нарисуйте там горку (рис.44)
Держа нажатой клавишу Alt, перетащите первый ключевой кадр слоя мячик до 50-го кадра. Тем самым вы создаете статические кадры. Выделите мяч и превратите его в графический символ, нажав клавишу F8 и выбрав тип Graphic (Графический).
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Рис.44: Исходный рисунок

Щелкните на позиции 15 верхней шкалы с делениями и нажмите клавишу F6 для создания ключевого кадра (рис.45). Выделите этот кадр и  переместите  на сцене мяч вниз направо к углу горки.
Щелкните на 35-м кадре при нажатой клавише Ctrl и снова нажмите клавишу F6 (рис. 45). Перетащите мяч вправо к концу горки.
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Рис.45: Промежуточный результат

Выделите последний кадр и сделайте его ключевым с помощью той же клавиши. Перетащите мяч вниз к нижнему краю сцены и поверните его на четверть оборота. Все ключевые кадры готовы, теперь можно начать анимацию. Выделите первый ключевой кадр и на панели Frame (Кадр), выберите в раскрывающемся списке Tweening (Промежуточная анимация) значение Motion (Движение), с помощью ползунка Eeasing (Ускорение) задайте значение -50, чтобы движение было ускоренным, в раскрывающемся списке Rotate (Вращение) выберите строку CW (По часовой стрелке), чтобы мяч вращался по часовой стрелке, а в поле Times (раз) введите значение 1. Для второго ключевого кадра сделайте то же самое, но задайте ускорение 50, а число оборотов – 2. Для третьего ключевого кадра задайте ускорение -100, а в раскрывающемся списке Rotate (Вращение) выберите строку Auto (Авто), чтобы мяч повернулся только на заданные четверть оборота. Должно получится то, что показано на рис.46.
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Рис.46: Конечный результат

Выполните команду Control ► Rewind (Управление ► Прокрутка назад) или щелкните на первом кадре, чтобы прокрутить анимацию назад, и нажмите клавишу Enter для просмотра.

Обязательно сохраните файл, так как он потребуется нам далее.
Движение по траектории

В анимации движения объекты могут перемещаться не просто по прямой от начального до конечного положения, но по любой заданной траектории. Траектория рисуется на слое направляющих, создать который можно командой Insert ► Motion Guide (Вставить ► Направляющая движения). Можно сделать это и командой Add Motion Guide (Добавить направляющую движения) контекстного меню, которое появляется при щелчке правой кнопкой мыши на слое с движущимся объектом в панели слоев.

Для каждого слоя с объектами создается свой слой направляющих, но можно привязать несколько слоев к одному слою направляющих, чтобы несколько объектов двигались по одной и той же траектории.

Начало и конец траектории должны быть точно совмещены с точкой регистрации символа или группы. Для этого следует использовать режим привязки к объектам, включить который можно командой View ► Snap to Objects (Вид ► Привязка к объектам). При неточном совмещении объект будет двигаться не по траектории, а по прямой. 
Для того чтобы объект двигался не параллельно самому себе, а так, чтобы его ось была все время направлена вдоль траектории движения, на панели Frame (Кадр) установите флажок Orient to Path (Ориентироваться по траектории).

Чтобы сделать траекторию невидимой при просмотре в программе Flash, спрячьте ее после создания анимации, выключив показ соответствующего слоя направляющих. Но это необязательно, так как в публикации направляющие все равно не видны.
Откройте файл, который вы создали в прошлом упражнении. Выделите слой с мячиком и выполните команду Insert ► Motion Guide (Вставить ► Направляющая движения) (рис.47). Это слой направляющих. Выделите слой направляющих и нарисуйте траекторию движения мяча (рис.48). Удобнее всего соединить эти точки через которые должен пройти мяч прямыми, а затем искривить их инструментом Arrow (Стрелка). 
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Рис.48: Направляющая

Заблокируйте слой с направляющими, чтобы не сдвинуть их с места. Чтобы спрятать траекторию, выключите показ слоя направляющих. Нажмите клавишу Enter и просмотрите анимацию.

Чтобы несколько объектов использовали одну и ту же траекторию движения, свяжите их слои со слоем направляющих. Для этого разместите их слои под слоем направляющих. Имена связанных слоев отображаются с отступом. Чтобы разорвать связь слоя с направляющей, перетащите его выше слоя направляющих или щелкните на имени слоя с объектом, держа нажатой клавишу Alt. Отступ при этом пропадает. Повторный щелчок при нажатой клавише Alt снова связывает слой с направляющей (рис.49).
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Рис. 49: Связь со слоем направляющих и разрыв связи
Для имитации неравномерного движения достаточно просто разбить одну анимацию движения на две. Для этого выделите промежуточный кадр или просто установите на него головку воспроизведения. Переместите объект в нужное место. В этом месте будет автоматически вставлен ключевой кадр, и вместо одной анимации вы получите две подряд.

Движение по замкнутой кривой

При анимации движения объекта по замкнутой траектории возникает следующая проблема. Flash всегда выбирает кратчайший путь от начального положения объекта до конечного. Поэтому, если расположить их рядом, или тем более на одном месте, объект сдвинется чуть-чуть или останется на месте.

Один из способов обойти это — сделать крошечный разрыв в контуре. Для создания такого разрыва достаточно провести по замкнутой кривой ластиком маленького размера при большом увеличении изображения.

Второй способ — оставить контур замкнутым, но разместить объект на конечном и начальном кадре на очень маленьком расстоянии друг от друга, а затем создать в середине анимации ключевой кадр, в котором объект находится на противоположной стороне траектории. Мы используем этот способ дальше.
Если замкнутая кривая представляет собой окружность, обеспечить движение объекта по ней еще проще. Для этого надо сдвинуть точку регистрации символа и расположить символ на сцене так, чтобы эта точка оказалась в центре вращения. Выполним это на практике.

Нарисуйте маленький шарик – кружок с радиальной градиентной заливкой – и превратите его в символ клавишей F8. Щелкните на кнопке Free Transform (Изменение).
 В центре шарика находится точка регистрации (рис. 50а). Сдвиньте точку регистрации в любую сторону на расстояние, равное нужному радиусу вращения (рис.50б).
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Рис. 50: Сдвиг точки регистрации
Создайте ключевой кадр на отметке 20, вернитесь на первый кадр и выберите на панели кадров анимацию движения. В раскрывающемся списке Rotate (Bpaщение) выберите движение по часовой стрелке, а в поле Times (раз) введите значение 1. Нажмите клавишу Enter для просмотра (рис.51).
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Рис.51: Результат анимации
Анимация форм

Анимация форм позволяет плавно превращать один контур в другой. Применять ее можно только к несгруппированным контурам. Кроме формы, при анимации могут меняться положение объекта, его размер и цвет. Лучшего результата можно добиться, если одновременно анимируется только один объект. Если же возникла необходимость изменить форму сразу нескольких объектов, их надо расположить на одном слое.

При анимации контуров с градиентной заливкой у исходного и конечного контура должен быть один и тот же тип градиентной заливки. Flash не умеет преобразовывать линейный градиент в радиальный и наоборот.

Принцип создания анимации такой же, как у анимации движения, но на панели кадров в раскрывающемся списке Tweening (Промежуточная анимация) надо выбрать режим Shape (Форма). Дополнительных параметров анимации всего два: Easing (Ускорение) и Blend (Перетекание). Ускорение имеет примерно такой же смысл, как для анимации движения. При отрицательных значениях контур преобразуется сначала медленно, потом быстрее, при положительных — наоборот.

В раскрывающемся списке Blend (Перетекание) выбирается режим перехода одной формы в другую. В режиме Distributive (Распределенный) у промежуточных контуров сглаживаются все углы, контуры выглядят более гладкими и округлыми, а процесс перетекания одной формы в другую похож на мультфильм «Пластилиновая ворона». В режиме Angular (Угловатый) Flash старается сохранить углы и прямые участки промежуточных контуров, насколько это возможно.
Создайте новый файл и нарисуйте в первом кадре круг. Создайте еще три ключевых кадра на расстоянии 15 кадров друг от друга. Нарисуйте в каждом кадре по одной фигуре (рис. 52). Старые фигуры удаляйте. Фигуры можно рисовать на одном месте, а можно и на некотором расстоянии друг от друга. Выберите для них разные цвета.
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Рис. 52: Анимация форм

Выделите первый кадр и выберите на панели Frame (Кадр) в раскрывающемся списке Tweening (Промежуточная анимация) режим Shape (Форма). То же самое сделайте для 15-го и 30-го кадров. Нажмите клавишу Enter и просмотрите анимацию.

Посмотрите, как будет выглядеть анимация при разных режимах перетекания и разных ускорениях. Если надо выполнить анимацию формы над текстом, символами или группами, надо прежде превратить их в обычные контуры командой Modify ► Break Apart (Изменить ► Разбить). Растровые изображения надо перевести в векторный вид командой Modify ► Trace Bitmap (Изменить ► Трассировать растр).

Применяя анимацию форм к очень сложным контурам, можно добиться лучших результатов, если разбить одну анимацию на несколько и самостоятельно нарисовать промежуточные контуры, какими они, на ваш взгляд, должны быть.

Анимация текста

Для текстовых блоков можно применять анимацию движения, перемещая текстовый блок, меняя его размер вместе с кеглем шрифта, вращая и перекашивая. Текст внутри блока при этом можно редактировать в любое время обычным образом. Однако если вы хотите плавно изменить в анимации цвет текста, то текстовый блок надо прежде превратить в символ и изменить его цвет в конечном кадре анимации с помощью панели Effects (Эффекты). Кроме цвета, на этой панели вы можете менять прозрачность текста, то есть он может медленно проявляться на экране или исчезать. Редактировать текст в символе можно, но только в режиме редактирования символа.

Создайте новый фильм. 
В первом кадре введите короткий текст черного цвета (рис. 53, сверху).
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Рис.53: Анимация текста

Щелкните на текстовом блоке инструментом Arrow (Стрелка) и превратите его в графический символ, нажав клавишу F8 и включив переключатель Graphic (Графический). Создайте ключевой кадр на отметке 10. В этом ключевом кадре перетащите надпись вниз, увеличьте ее размеры и поверните под углом, как показано на рис. 53 снизу.

Откройте панель эффектов и сделайте надпись цветной, выбрав в раскрывающемся списке режим Tint (Оттенок). Выделите первый кадр и выполните команду Insert ► Create Motion Tween (Вставить ► Создать анимацию движения). Нажмите клавишу Enter для просмотра.

В случае если символы текста должны перемещаться в анимации по отдельности или должны деформироваться в процессе анимации, необходимо сначала преобразовать текст в отдельные контуры командой Modify ► Break Apart (Изменить ► Разбить). Если вы собираетесь применить анимацию движения, следует превратить все буквы в объектные символы. Впрочем, если несколько идущих подряд букв должны вести себя одинаково, их можно записать в один символ. Для анимации форм следует оставить полученные контуры как есть. В любом случае, после преобразования в контуры текст уже нельзя редактировать.

Использование сцен

Создание сложного фильма упростится, если его разделить на сцены, создавая новые сцены с появлением новых персонажей фильма. При монтаже фильма гораздо проще менять местами сцены, чем переставлять кадры одной сцены. Легко добавить новые эпизоды в начале или в середине фильма, просто вставив там новые сцены. При построении сайта принято делить материал сайта по темам, используя отдельные сцены для стартовой страницы сайта, для информационной страницы и т. д.

Каждая сцена имеет свою временную линейку. Сцены создаются и отлаживаются независимо друг от друга. Как правило, команды проигрывания действуют только в пределах текущей сцены, но можно просматривать и прокручивать весь фильм как единое целое. Если фильм показывается циклично, то после последнего кадра последней сцены снова идет первый кадр первой сцены.

Каждая сцена имеет независимую нумерацию кадров, но при экспорте в SWF-фай, используется сквозная нумерация, причем сцены идут в том порядке, в котором они перечислены на панели Scenes (Сцены). Для вызова этой панели на экран выполните команду Window ► Other Panels ► Scene (Окно ► Другие панели ► Сцена).

Эта панель служит для работы со сценами, и ее единственное содержимое – это перечень сцен и три кнопки внизу (рис. 54). Для создания новой сцены выполните команду Insert  Scene (Вставить сцену) или щелкните на кнопке Add Scene (Добавить сцену) внизу панели сцен. Новая сцена вставляется после текущей Сцены. Ей дается название Scene N, где N — номер сцены. Чтобы переименовать сцен дважды щелкните на ее имени и введите новое имя.
Для перехода к заданной сцене используйте следующие команды или клавиши: 
· First (Первая) — переход на первую сцену фильма (клавиша Home)
· Previous (Предыдущая) — переход на предыдущую сцену (PgUp)
· Next (Следующая) — переход на следующую сцену (PgDn)
· Last (Последняя) — переход на последнюю сцену (End).

Вы найдете эти команды в подменю, выполнив команду View ► Goto (Вид ► Перейти).

Следом за перечисленными командами в этом меню идет перечень сцен. Чтобы выбрать сцену, щелкните на ее имени. Точно так же можно выбрать сцену по ее имени на панели сцен или в списке, который появляется, если щелкнуть на кнопке Edit Scene (Редактировать сцену) в верхнем правом углу окна документа.

Можно использовать дубликат сцены в качестве отправной точки для создания новой сцены или для сохранения ее резервной копии. Для дублирования текущей сцены щелкните на кнопке Duplicate Scene (Дублировать сцену) внизу панели сцен. Чтобы изменить порядок расположения сцен в списке, нажмите кнопку мыши на имени сцены и тащите его вниз или вверх. Когда в требуемом месте вставки появится жирная черта, отпустите кнопку мыши.

Для удаления текущей сцены щелкните на кнопке Delete Scene (Удалить сцену) или выполните команду Insert ► Remove Scene (Вставить ► Удалить сцену).

Урок 9. «Озвучка»

Возможности работы со звуком в программе Flash не очень велики, но не так и малы. Их хватает, чтобы озвучить короткими звуками события или «пустить» за кадром циклично повторяющуюся мелодию. У вас есть возможность настраивать звук, заставляя его нарастать или затухать. При этом можно редактировать независимо звук от левого и правого динамика. Из длинного звукового файла можно вырезать нужную часть, чтобы в публикацию вошел не весь длинный звуковой файл, а ровно столько, сколько нужно. Поскольку звуковые файлы, как правило, большого, даже огромного, размера, это играет существенную роль. Кроме того, у вас есть еще возможность сжимать звук в широких пределах, следя при этом, насколько сильны искажения, вызванные сжатием.

Звуки в программе Flash делятся на событийные и потоковые. Событийный звук начинает звучать только после того, как полностью загрузится, но тогда уж звучит, пока его не остановишь. Потоковый звук начинает играть сразу же, как только загрузится его часть, достаточная для нескольких первых кадров, остальное подгружается уже во время звучания первых тактов. Потоковая мелодия синхронизирована с временной линейкой анимации, в сущности, она намертво встраивается в кадры фильма.

Событийный звук от временной линейки не зависит, если не считать того, что он начинает звучать в том кадре, в который его вставили. При размещении звука в кадрах кнопки он будет раздаваться при определенном событии, например, при щелчке на кнопке. Звуком можно управлять и программно, с помощью сценариев, но об этом мы говорить не будем.
Импорт звука

Начинается работа со звуками с их импорта. Работая в среде Windows, вы можете использовать звуковые файлы в форматах WAV и МРЗ. 
Звук, как и растровая графика, импортируется командой File ► Import (Файл ► Импорт). Далее звук автоматически записывается в библиотеку, чтобы вы могли вставлять его в фильм много раз, не увеличивая размеров файла. Чтобы уменьшить размеры файлов с озвученным фильмом, звук сжимается. Параметры сжатия можно задавать для каждого звука из библиотеки индивидуально, а можно задать их сразу для всех звуков фильма в окне настройке публикации при выводе фильма.

В комплект Flash входит общая библиотека звуков. Она в основном содержит всевозможные лязги и стуки. Вы можете открыть ее, выполнив команду Window ► Common Libraries ► Sounds (Окно ► Общие библиотеки ► Звуки).  Хотя, эта библиотека не всегда входит в стандартную поставку. Чтобы прослушать какой-либо звук, щелкните на его имени правой кнопкой мыши и выберите в контекстном меню команду Play (Играть) или щелкните на правой кнопке в окне предварительного просмотра.
Размещение звуков в кадрах

При озвучивании фильма звук или несколько звуков из библиотеки можно разместить на любом слое, однако рекомендуется размещать звуки на отдельных слоях, где нет других объектов, и для каждого звука создавать отдельный слой. Это даст вам больше возможностей по комбинированию разных звуков. Они могут звучать одновременно, начинаясь в разное время, так как каждый слой выступает в роли звуковой дорожки.

На временной линейке для этого слоя надо создать один ключевой кадр, который определяет начало звучания. Звук можно либо поместить на сцену в этом кадре, либо выбрать его в верхнем раскрывающемся списке панели Sound (Звук), показанной на рис. 55. Здесь находится список всех звуков из библиотеки фильма. Звук можно поместить только в ключевом кадре. Если попытаться вставить его в статический кадр, он будет вставлен в ближайший слева ключевой кадр.
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Рис.55: Вставка звука в кадр

При размещении звука в кадре на временной линейке появляется осциллограмма звука; По ней можно судить, как долго (то есть сколько кадров) будет звучать звук. 
Проще всего озвучить кнопку. Добавьте из библиотеки элементов кнопку так, как мы это делали в прошлом уроке. Выберите инструмент Arrow (Стрелка) и дважды щёлкните по кнопке 

Создайте новый слой для звука, назовите его, например, щелчок. В этом слое создайте ключевой кадр на отметке Down (Нажата), выделите его и перетащите на сцену звуковой символ из библиотеки. Можно поступить иначе. Выделив этот ключевой кадр, откройте панель Sound (Звук). В верхнем раскрывающемся списке вы найдете все звуки, которые есть в библиотеке фильма. Если в библиотеке звуков нет элементов, то импортируйте туда один (можно несколько) звуковых файлов.

Выберите звук. На временной линейке появляется осциллограмма звука. Нажмите клавиши Ctrl+Enter для тестирования фильма. Наведите указатель на кнопку и щелкните, чтобы проверить, на месте ли звук. 

Если добавить, например, файл с какой-либо песней, то мы получим простенький проигрыватель, в библиотеке которого будет всего одна мелодия и звучать она будет по нажатию кнопки. 
Настройка звука

Прежде чем говорить о настройке звука, разберемся в сущности параметров, о которых дальше пойдет речь.

Если опустить некоторые подробности, то при переводе физического звука в цифровой с определенной частотой измеряется и записывается амплитуда звука. Частота измерения называется частотой оцифровки. Чем больше эта частота, тем точнее будет цифровая запись воспроизводить исходную музыку, но тем больше памяти потребуется для нее. В основном искажения касаются высоких тонов, так как в принципе нельзя измерить звук, частота которого больше половины частоты оцифровки. (Амплитуда успевает совершить одно или несколько колебаний между двумя измерениями.)

Программа Flash способна импортировать звуки с частотой оцифровки 11, 22 и 44 КГц, однако при экспорте можно снизить эту частоту, чтобы уменьшить размеры файла публикации. Можно импортировать в программу Flash звук с частотой оцифровки, не кратной 11 КГц. но при импорте звук будет пересчитан и приведен к ближайшей 11-кратной частоте.

Второй важный параметр звука — разрядность отсчетов. На запись каждого значения амплитуды отводится некоторое количество бит, как правило, 8 или 16. При 8-битовой разрядности весь диапазон звуков делится на 256 (28) уровней. Вместо гладкой кривой вы получите кривую с довольно грубыми ступеньками. При 16-битвой разрядности можно передать уже 65 536 (210) уровней звука. Звук воспроизводится гораздо точнее, но опять за счет роста размеров файла.

Ну и наконец, звук может быть моно или стерео. Монозвук содержит только один звуковой канал, а стереозвук — два: для левого и правого уха. Соответственно, стереозвук требует ровно в два раза больше памяти, чем монозвук.

Звук настраивается в двух местах: в библиотеке и на панели Sound (Звук). В библиотеке выбирается степень сжатия звука при публикации фильма, а на панели Sound (Звук) можно сменить тип звука, создать для него различные эффекты, включить циклическое повторение звука, а также вызвать окно редактирования звука.

Еще один параметр, самый существенный при передаче звука по сети, - это битовая скорость (битрейт). Она отражает степень сжатия звука и означает количество бит, нужное для записи секунды звучания музыки. Чем больше эта скорость, тем больше сжат звук и тем хуже качество записи. Сравнивая битовую скорость звука после сжатия и пропускную способность канала, вы можете понять, сможет ли звук звучать непрерывно в процессе загрузки или его надо сначала весь загрузить, чтобы гарантировать непрерывность звучания.
Импортировав звук и вставив его в кадр, можно затем с помощью панели Sound (Звук) создавать звуковые эффекты за счет ослабления звука. В раскрывающемся списке Effects (Эффекты) выбираются стандартные эффекты:

· None (Нет) – никаких эффектов, это значение используется по умолчанию или для удаления заданного эффекта
· Left Channel (Левый канал) – звучит только левый динамик
· Right Channel (Правый канал) – звучит только правый динамик
· Fade Left to Right (Затухать слева направо) – звук в левом динамике затихает, а в правом усиливается, создавая впечатление движения слева направо
· Fade Right to Left (Затухать справа налево) – впечатление движения справа налево
· Fade In (Затухать на входе) – звук нарастает от нуля до нормального звучания
· Fade out (Затухать на выходе) – звук затихает от нормального звучания до нуля.

Если выбрать в этом раскрывающемся списке значение Custom (Пользовательский), то можно создать свой собственный эффект, самостоятельно отредактировав звуковые каналы. Чтобы начать «плясать» от какого-либо из стандартных эффектов, выберите его в раскрывающемся списке, а затем щелкните на кнопке Edit (Правка). Подробнее о редактировании пользовательского эффекта см. далее.

Синхронизация звука и циклическое звучание

Тип синхронизации звука выбирается в раскрывающемся списке Sync (Синхронизация) панели звуков. В вашем распоряжении четыре варианта:

· Event (Событие) — событийный звук, начинается одновременно с показом ключевого кадра, к которому он привязан, и звучит полностью, даже если фильм закончился. При циклическом повторе фильма одновременно может звучать начало звука и его же продолжение из предыдущего цикла. Если звук достаточно длинный, то может произойти множественное наслоение звука на самого себя. Событийный звук чаще всего применяется для кнопок
· Start (Старт) — этот тип практически идентичен событийному, но за одним исключением: если звук должен начаться, но еще звучит его продолжение из прошлого цикла, он не включится. Это гарантирует, что не произойдет наслоения одного и того же звука при циклическом исполнении фильма или клипа
· Stop (Стоп) — этот тип синхронизации служит для того, чтобы выключить заданный звук, если он звучит. На другие звуки он не действует. Используется, когда одновременно слышно несколько звуков, один из которых надо остановить
· Stream (Поток) — потоковый звук, кадры строго привязаны к музыке. Если Flash не успевает нарисовать на экране нужные кадры, они просто пропускаются, чтобы не отстать от мелодии. При прекращении фильма звук также останавливается. Этот тип синхронизации используется тогда, когда надо обеспечить точное соответствие звука и анимации.

Для того чтобы звук повторялся в фильме несколько раз, введите число повторов в поле Loop (Цикл). Если надо обеспечить постоянное звучание, введите число, заведомо большее, чем может понадобиться.

Не рекомендуется использовать циклический повтор для потоковых звуков. Дело в том, что событийный звук вставляется в фильм только один раз, в первом месте, где он используется. Как при работе с графическими символами, при его циклическом повторе используется его копия — экземпляр звукового символа. Совсем по-другому вставляется в фильм потоковый звук. При публикации он разрезается на части и «раскладывается» по соответствующим кадрам. Поэтому при повторе потокового звука в конец фильма вместе со звуком добавляются дубликаты соответствующих кадров. Каждый повтор, таким образом, увеличивает размеры файла.
Редактирование звуковых каналов

Как уже говорилось выше, для создания собственного эффекта выберите редактируемый звук в списке панели эффектов, а затем щелкните на кнопке Edit (Правка). В диалоговом окне Edit Envelope (Правка огибающей) вы можете редактировать отдельно левый и правый канал звука (рис. 56). В строгом смысле это, конечно, не редактирование, а управление ослаблением звука.
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Рис. 56: Редактирование эффекта
В верхней части окна находится осциллограмма звука для левого канала, в нижней – для правого. В каждом их них вы видите ломаную линию – огибающую звука. На ней находятся квадратные манипуляторы, с помощью которых вы можете менять форму огибающей. Форма огибающей определяет степень ослабления исходной амплитуды звука в зависимости от времени. Когда она проходит «по потолку», звук никак не ослабляется, когда она опускается «до пола», звук полностью гасится. Управлять огибающей очень просто: перетаскивайте горизонтальные прямые или манипуляторы. Чтобы создать на огибающей дополнительные манипуляторы, достаточно щелкнуть на ней в нужных местах. Манипуляторы создаются одновременно в верхнем и нижнем окнах, по горизонтали они перемещаются вместе, а по вертикали – независимо друг от друга. Чтобы удалить манипулятор, надо совместить его с соседним манипулятором или перетащить за край окна.

Между окнами находится шкала времени. Она может измеряться либо в секундах, либо в кадрах. Переключаться между этими двумя режимами можно с помощью двух крайних справа кнопок внизу диалогового окна. Две соседние кнопки позволяют уменьшать или увеличивать масштаб по оси времени, чтобы сжимать или растягивать осциллограмму звука в диалоговом окне. Для перемещения по длинной осциллограмме служит полоса прокрутки внизу окна.

На временной шкале слева и справа находятся маркеры начала и конца звука. Перемещая их, вы можете вырезать из длинной звуковой записи только нужный вам кусок. Вместо того чтобы останавливать длинный звук, можно обрезать его здесь. При обрезании звука, который намного дольше, чем длительность фильма, сжимайте осциллограмму в окне, иначе вам придется перетаскивать маркер «целую вечность».

Начинать создание нового эффекта можно с любого стандартного эффекта. Выберите его в верхнем раскрывающемся списке, а дальше меняйте, как хотите. Чтобы прослушать, что стало со звуком после применения вашего эффекта, используйте две кнопки слева внизу диалогового окна. Они имеют стандартные обозначения для кнопок проигрывания и паузы.

Окно свойств звука
Параметры звука можно изменить в диалоговом окне Sound Properties (Параметры звука), показанном на рис. 57.
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Рис.57: Окно свойств звука
Для того чтобы вызвать это окно, дважды щелкните на значке звукового символа в библиотеке или выделите имя символа и щелкните на кнопке Properties (Параметры) внизу библиотеки.

В верхнем поле этого окна можно ввести другое имя для звука. По умолчанию здесь появляется имя файла, но лучше задать имя, которое подскажет вам, для чего нужен данный звук. Особенно стоит сменить имя, если в библиотеке несколько звуков с одним названием (а такое вполне может быть). Правда, проще имя сменить в самой библиотеке, дважды щелкнув на имени звука и введя новое имя.

Ниже поля с именем звука вы найдете информацию о местонахождении звукового файла на диске, о времени его последней модификации и о параметрах звука и звукового файла. Параметры приводятся в следующем порядке: частота оцифровки звука, разрядность отсчетов, моно- или стереозвук, длительность звука в секундах и размер файла.

В правой части окна находятся кнопки, которые позволяют выполнять различные операции с импортированным звуком. Если звуковой файл менялся во внешнем редакторе звуков, обновите его, щелкнув на кнопке Update (Обновить).

Кнопка Import (Импорт) позволяет сменить файл-оригинал, найдя на диске другой файл и дважды щелкнув на его имени. Эффекты, заданные для звука, при этом остаются.
Сжатие звука при публикации

Способ и параметры сжатия звука выбираются в нижней части окна Sound Properties (Параметры звука). Для разных способов сжатия вы будете задавать разные параметры звука, но для всех способов работает одно правило: чем больше сжатие, тем хуже качество звука. Ваша задача – подобрать оптимальное соотношение между качеством звука и размерами файла. Информация о размерах звукового файла после сжатия, в том числе в процентах от исходного размера, приводится в нижней строке окна.

Щелкнув на кнопке Test (Тест), вы можете сжать звук с заданными параметрами и прослушать его. Меняя параметры и каждый раз щелкая на этой кнопке, подберите оптимальный режим сжатия. Если запись длинная, можете прерывать ее кнопкой Stop (Стоп).

Сначала выберите способ сжатия в раскрывающемся списке Compression (Сжатие). Доступные варианты: Default, ADPCM, МРЗ, Raw и Speech. Если оставить выбранный по умолчанию вариант Default (По умолчанию), то будет использоваться режим сжатия, заданный в окне Publish Settings (Установки публикации).

Способ сжатия ADPCM используется для коротких событийных звуков с разрядностью 8 или 16 бит. Перед сжатием можно преобразовать стереозвук в монозвук, установив флажок Convert Stereo to Mono (Преобразовать стерео в моно).

В раскрывающемся списке Sample Rates (Частота оцифровки) можно уменьшить частоту оцифровки. В списке имеются значения 5, 11, 22 и 44 КГц. 11 КГц — минимальная частота, приемлемая для коротких музыкальных фрагментов, Чаще всего для музыки в Web-графике используется частота 22 КГц, она дает более или менее приличное качество. 44 КГц — стандартная частота для компакт-дисков, при ее использовании размеры звуковых файлов очень велики и мало подходят для целей анимации. В раскрывающемся списке ADPCM Bits выберите разрядность, которая будет использоваться при кодировке звука. Она может меняться от 2 до 5 бит. Чем она больше, тем меньше будет искажений в звуке после сжатия. Выбирать значения частоты большие, чем в исходном звуковом файле, нет смысла – все равно будет использоваться исходная частота.

Для длинных потоковых звуков лучше использовать сжатие в режиме МРЗ. Даже если потоковый звук был импортирован в формате МРЗ, его все равно надо еще раз сжать перед экспортом. В раскрывающемся списке Bits Rate (Битовая скорость) выберите битовую скорость звука. Для музыки не следует использовать битовую скорость меньше 16 Кбит/с.

Перед сжатием можно преобразовать стереозвук в монозвук, установив флажок Convert Stereo to Mono (Преобразовать стерео в моно). Учтите, что этот флажок работает только при битовых скоростях больше 10 бит/с.

В раскрывающемся списке Quality (Качество) выбирается скорость сжатия и, соответственно, качество звука. Чем больше скорость, тем хуже качество. Варианты выбора: Fast (Быстрое), Medium (Среднее) и Best (Наилучшее).

В режиме сжатия Raw звук экспортируется без сжатия за счет перекодировки. Все, что делается для уменьшения размеров файла, - это преобразование стереозвука в монозвук (тот же флажок, что и для других режимов сжатия) и уменьшение частоты оцифровки (в вашем распоряжении те же частоты, что и для режима ADPCM).

При желании вы можете экспортировать все звуки из фильма в WAV-файл. Для этого выполните команду File ► Export Movie (Файл ► Экспорт фильма) и выберите в списке формат WAV.
Урок 10. «Вывод фильма»

Настройка публикации

Настройка публикации выполняется в окне Publish Settings (Настройка публикации). Это окно вызывается одноимённой командой меню File (Файл). Его внешний вид приведён на рис.58. Настройки, произведённые в этом окне, сохраняются вместе с авторским фильмом, в отличие от настроек в окне экспорта.
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Рис.58: Настройка публикации

На вкладке Formats (Форматы) вы можете выбрать форматы, которые хотите включить в публикацию. При включении каждого формата в окне настройки появляется новая вкладка для настройки экспорта в этот формат. Чтобы включить формат просто установите соответствующий флажок.

По умолчанию файлам даётся имя, которое было у авторского фильма, но, естественно с другим расширением. Чтобы дать файлам другие имена просто напечатайте их в поле справа от формата. Для возвращения стандартных имён используется кнопка Use Default Names (Использовать стандартные имена).
Если вы хотите разместить файлы в разных папках, то просто щёлкните на значке папки справа от поля имени файла и укажите нужныё путь.

Настройка формата SWF
Для настройки экспорта в формате SWF откройте вкладку Flash (рис. 59).
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Рис. 59: Настройка формата Flash
В верхнем раскрывающемся списке можно выбрать версию плеера, который может быть использован для просмотра. При  этом необходимо учитывать, что Flash Player 7 не сможет воспроизвести файлы, созданные для Flash Player 8. 

В следующем поле можно выбрать порядок, в котором будут загружаться слои фильма для показа первого кадра. Это существенно при загрузке фильма через модем на медленных линиях, когда изображение появляется постепенно. По умолчанию используется режим Bottom Up (Снизу вверх).
В выпадающем списке Action Script Version указывается версия скрипта для обработки файла. Это используется, например, при создании меню для сайта. В нашем учебнике это не рассматривалось.
Далее в поле Options (Параметры) находится несколько флажков, управляющих режимом экспорта в SWF-файл:
· Generate size report (Создавать отчет о размерах) - если этот флажок установлен, то при публикации и той же папке, где хранится авторский фильм, будет создаваться текстовый файл с отчетом о размерах кадров, символов, звуков и других элементов фильма

· Omit Trace actions (Опустить оператор Trace) – при установленном флажке игнорируются осе вхождении оператора Trace. Этот оператор используется в целях отладки для вывода значения переменных в окно Output (Вывод).

· Protect from Import (Защита от импорта) – при публикации с установленным флажком создаётся SWF файл, который не возможно импортировать в программу Flash.
· Debugging Permitted (Отладка разрешена) – если флажок установлен, можно использовать окно Debugger (Отладчик) при просмотре публикации в браузере, если знать пароль.
С помощью ползунка JPEG Quality (Качество JPEG) регулируется степень сжатия, а следовательно и качество всех растровых импортированных изображений. 

Ниже находятся две кнопки Set (Установить), которые вызывают окно общей настройки звука.  Верхняя кнопка под названием Audio Streem (Потоковый звук) настраивает потоковый звук, а нижняя – Audio Event (Событийный звук) – событийный.
Настройка HTML-файла

Настройки вкладки HTML (рис. 60) определяют параметры кода в HTML-файле, размещающем на Web-странице фильм (или растровое изображение) как встроенный объект. От этих установок зависит режим проигрывания фильма, его местонахождение в окне браузера, размеры отведённой для него области и способы обрезки и масштабирования фильма.
В верхнем раскрывающемся списке Template (Шаблон) перечислены шаблоны, которые используются для автоматической генерации HTML-файла. Рядом со списком находится кнопка Info (Информация), с помощью которой вы можете получить пояснения к содержимому шаблона. В списке имеются следующие шаблоны:

· Ad 3 (4, 5) Banner – эти три шаблона используются для создания Aftershock-баннера. В HTML-файле, созданном по этим шаблонам, используются сценарии, проверяющие, имеется ли у пользователя проигрыватель Flash Player, соответственно, 3, 4 или 5-й версии

· Flash Only (Default) – этот шаблон, самый простой, используется по умолчанию. Все, что он делает, это размещает в браузере один SWF-файл;

· Flash with FSCommand – шаблон используется для фильмов, и которых применялся оператор FSComand. Этот оператор (мы его не рассматривали) передает команды среде программного окружения проигрывателя

· Image Map – шаблон используется для показа в браузере только изображений в форматах GIF, JPEG или PNG. Для этого на вкладке форматов флажок Flash должен быть снят, а флажок для одного из указанных графических форматов – установлен

[image: image42.jpg]Publish Settings. X

Curent profie et v ) +[=[0|s
Formats | Flash | HTL |
Tompae: [EEIERD ¥ e
[loetect Fsh version
version: 8
Dimensions: [tzh Hovie v
widhi et
% icls
Payback: [lpaused atstart  [Diplay menu
oop Cloevie fort
Quaty: [rgh 9
Wwindow Hode:. [Window v
ML lgnments [Defeut B
e [Defouk Showal) v
Horzntal el
O e

how warring messages

o) Coo )





Рис.60: Настройка HTML-файла
· Java Player – шаблон используется для показа фильма, проигрываемого с помощью Flash Java Player. Этот проигрыватель, который вы найдете в папке 
· Quick Time – этот шаблон предназначен только для публикации фильмов в формате QuickTime;

· User Choice – с помощью этого шаблона создается Web-страница, па которой зритель сам выбирает нужный формат фильма. Этот шаблон имеет смысл выбрать, если вы одновременно «заказали» SWF и какой-либо другой графический формат (GIF, JPEG или PNG).

В раскрывающемся списке выберите значение Percent (Проценты), чтобы задать размеры фильма в процентах от размеров окна браузера, или значение Pixels (Пикселы), чтобы задать фиксированный размер фильма в пикселях. Сами размеры задайте ниже в полях Width (Ширина) и Height (Высота). Если в списке выбрано значение Match Movie (Как в фильме), то размеры области точно совпадают с размерами фильма, взятыми из окна Movie Properties (Свойства фильма).

В разделе Playback (Проигрывание) находятся четыре флажка, управляющие режимом проигрывания фильма в браузере:

· Paused at Start (Пауза в начале) – если этот флажок установлен, то после загрузки фильм не проигрывается, а ждет сигнала от зрителя. Сигналом может быть щелчок на запрограммированной вами кнопке, другое запрограммированное действие или выполнение команды Play (Проиграть) основного или контекстного меню проигрывателя
· Loop (Цикл) – при установленном флажке основной фильм повторяется циклично

· Display Menu (Покалывать меню) – при снятом флажке контекстное меню проигрывателя будет заблокировано

· Device Font (Шрифт устройства) – при установленном флажке вместо отсутствующих сглаженных шрифтов будут использоваться шрифты, имеющиеся на компьютере зрителя. Замена выполняется только для статического текста, для которого на панели Text Options (Параметры текста) был установлен флажок Use device fonts (Использовать шрифты устройства),

В раскрывающемся списке Quality (Качество) выберите приоритеты между качеством прорисовки кадров и отсутствием задержек при проигрывании фильма:

· Low (Низкое) – наихудшее качество, сглаживание изображения не производится, явно отсутствие задержек между кадрами практически гарантировано
· Auto Low (Низкое автоматическое) – скорость показа кадров имеет больший приоритет. Показ начинается при выключенном сглаживании, но если проигрыватель «решает», что можно успеть сделать сглаживание, оно выполняется;

· Auto High (Высокое автоматическое) – приоритеты примерно равны. Показ начинается с включенным сглаживанием, но если скорость показа кадров падает ниже заданной, сглаживание выключается

· Medium (Среднее) – сглаживание выполняется, но не для растровых изображений
· High (Высокое) – больший приоритет имеет качество изображения. Сглаживание выполняется при любых условиях. Однако для растровых изображений оно выполняется только при отсутствии в фильме анимации;

· Best (Наилучшее) – на скорость проигрывания не обращается никакого внимания; как векторная, так и растровая графика всегда сглаживаются. 
В раскрывающемся списке Window Mode (Режим окна) можно выбрать разные режимы размещении и показа фильма в браузере Internet Explorer 4.0 пол управлением модуля Flash ActiveX:

· Window (Окно) – фильм проигрывается в отдельном окне Web-страницы, этот режим показа самый быстрый
· Opaque Windowless (Непрозрачный без окна) – окно с Flash-фильмом непрозрачно, так что другие объекты сквозь него не видны
· Transparent Windowless (Прозрачный без окна) – фон фильма прозрачен, так что объекты, расположенные под фильмом, просвечивают сквозь него. Этот режим может замедлять показ фильма.

В раскрывающемся списке HTML Alignment (Выравнивание HTML) выбирается режим выравнивания фильма относительно окна браузера. При выборе значения Default (По умолчанию) фильм центрируется относительно окна браузера, а то, что выходит за рамки окна браузера, обрезается. При выборе одного из значений, Left (Слева), Right (Справа), Тор (Сверху) или Bottom (Снизу), фильм выравнивается по соответствующему краю окна браузера, а остальные три стороны при необходимости обрезаются.

В раскрывающемся списке Scale (Масштаб) выберите способ масштабирования фильма, если для него отведена область меньше его исходных размеров: 
· Show All (Показать все) – фильм масштабируется одинаково по ширине и высоте, так, чтобы он был виден целиком. С двух сторон при этом могут оставаться пустые поля
· No Border (Без полей) – фильм также масштабируется пропорционально, но так, чтобы никаких пустых полей не оставалось. Для этого он может обрезаться с двух сторон
· Exact Fit (Подогнать точно) – фильм масштабируется по-разному по ширине и высоте, так, чтобы заполнить всю отведенную ему область.
Способ масштабирования соответствует в HTML-файле параметру SCALE в тегах OBJECT и  EMBED. 
Два раскрывающихся списка в разделе Flash Alignment (Выравнивание Flash) задают выравнивание фильма внутри отведенной ему области. В списке Horizontal (По горизонтали) задается выравнивание фильма по горизонтали:

· Left (Слева) – выравнивание по левой границе
· Center (По центру) – выравнивание по центру
· Right (Справа) – выравнивание по правой границе.

В списке Vertical (Вертикальный) аналогичные три значения выравнивают фильм по вертикали:

· Тор (По верху) – выравнивание по верхней границе
· Center (По центру) — выравнивание по центру
· Bottom (По низу) — выравнивание но нижней границе.

При установленном флажке Show Warning Messages (Показывать предупреждения об ошибках) па экран выводится сообщение об ошибке, если есть несоответствие между установками, например, если выбран шаблон Image Map, но ни одного растрового формата для публикации не заказано.
Предварительный просмотр публикации

Чтобы проверить, как будет выглядеть публикация при заданных установках, выполните команду File ► Publish Preview (Файл ► Предварительный просмотр) и выберите в списке формат, который вы хотите увидеть. В этом списке будут все форматы, которые вы выбрали на вкладке форматов.

При выборе формата HTML генерируется HTML-файл и файл с публикацией в формате SWF. Они загружаются в браузер, используемый на вашем компьютере по умолчанию. Если выбрать формат SWF, то файл публикации будет показан в среде тестирования. Чтобы быстро выполнить предварительный просмотр публикации в формате HTML, нажмите клавишу F12.

При выполнении команды предварительного просмотра файл в нужном формате создается в той же папке, где хранится авторский фильм.
Экспорт фильмов

Помимо публикации в редакторе Flash предусмотрен и экспорт как таковой. Команда File ► Export Movie (Файл ► Экспорт фильма) экспортирует все кадры фильма только в один заданный формат. Настройка экспорта выполняется тут же, по ходу экспорта. В зависимости от того, поддерживает ли выбранный формат анимацию, создается либо один файл с анимацией, либо пронумерованная последовательность статических изображений (каждый кадр в отдельном файле). Команду Export Movie (Экспорт фильма) можно также использовать для экспорта звуков в один файл формата WAV.

Экспорт можно использовать, если вы собираетесь редактировать фильм в других графических приложениях или не нуждаетесь в помощи Flash для создания Web-страницы и вам нужен только SWF-файл, анимированный GIF или файлы другого формата. Для экспорта только текущего кадра фильма используйте команду File ► Export Image (Файл ► Экспорт изображения). Настройки, произведенные в процессе экспорта, в фильме не сохраняются.
При выполнении команды File ► Export Movie (Файл ► Экспорт фильма) или File ► Export Image (Файл ► Экспорт изображения) открывается окно экспорта (рис. 61). Оно выглядит одинаково для обеих команд, за исключением содержимого списка File of Type (Тип файла). При экспорте фильма для форматов, которые не поддерживают анимацию, тип файла включает в себя слово Sequence (Последовательность).

[image: image43.jpg]Export Movie

)

Henaerie
oxyenTel

2.

®

Mo gorguenet

5

Mai
KonmeiTen

Q

Ceresae

SR

(EProject
(2 sample.

Voo parina:

Tum i

[Copanm

Flash Movie [*swf)

—





Рис.61: Экспорт фильма
Чтобы выполнить экспорт, найдите папку для хранения файла, выберите нужный формат в списке File of Туре (Тип файла) и введите имя файла. Щелкните на кнопке Save (Сохранить). Если формат настраивается, откроется окно настройки экспорта. Если не настраивается, сразу же выполняется экспорт.

При экспорте в векторные форматы (Adobe Illustrator, AutoCAD, EMF, WMF) изображение сохраняется в векторном виде, так что вы можете редактировать его в соответствующих векторных редакторах. При экспорте в растровые форматы (BMP. GIF, JPEG) вся информация о векторных контурах теряется, и файл можно редактировать только в растровых редакторах, таких как Photoshop, Paint, Paintbrush и др.

Экспорт в форматы EPS, AutoCAD, EMF и WMF не настраивается. При экспорте в формат Adobe Illustrator единственное, что вы можете, - это выбрать версию Adobe Illustrator. Экспорт в формат QuickTime настраивается точно так же, как в окне настройки публикации. Настройку остальных форматов мы рассмотрим сейчас подробнее.
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Рис.16 – Настройка кисти
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Рис. 18: Создание опорных точек
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Рис. 24: Настройка градиента	
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Рис.31: Перемещение объектов
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Рис. 43: Анимация
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